summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 12:24:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 12:40:54 +0200
commitcdbde885bb6a602e13184552997a143e189705fe (patch)
tree0b72de5e1825611721d5ba5ed88bec2849074431 /dev-python/dnspython
parentdev-python/python-email-validator: Remove old (diff)
downloadgentoo-cdbde885bb6a602e13184552997a143e189705fe.tar.gz
gentoo-cdbde885bb6a602e13184552997a143e189705fe.tar.bz2
gentoo-cdbde885bb6a602e13184552997a143e189705fe.zip
dev-python/dnspython: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/dnspython-2.2.1.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/dnspython/dnspython-2.2.1.ebuild b/dev-python/dnspython/dnspython-2.2.1.ebuild
index fd6c6844ee59..beb937eab99a 100644
--- a/dev-python/dnspython/dnspython-2.2.1.ebuild
+++ b/dev-python/dnspython/dnspython-2.2.1.ebuild
@@ -4,13 +4,20 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
inherit distutils-r1
DESCRIPTION="DNS toolkit for Python"
-HOMEPAGE="https://www.dnspython.org/
- https://pypi.org/project/dnspython/"
-SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
LICENSE="ISC"
SLOT="0"
@@ -19,7 +26,8 @@ IUSE="examples"
RDEPEND="
dev-python/cryptography[${PYTHON_USEDEP}]
- <dev-python/idna-4.0[${PYTHON_USEDEP}]"
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]
+"
distutils_enable_tests pytest