summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-10-31 16:07:06 -0500
committerAlex Brandt <alunduil@gentoo.org>2015-10-31 16:07:06 -0500
commit130d532768a0b5fbaed45b164f96e92d144c1c2b (patch)
treef5937a16f80cfe128912cddb86fbd8b0a64e949c /dev-python/doublex-expects/doublex-expects-0.7.0_rc2.ebuild
parentapp-office/libreoffice-l10n: Remove old (diff)
downloadgentoo-130d532768a0b5fbaed45b164f96e92d144c1c2b.tar.gz
gentoo-130d532768a0b5fbaed45b164f96e92d144c1c2b.tar.bz2
gentoo-130d532768a0b5fbaed45b164f96e92d144c1c2b.zip
dev-python/doublex-expects: add version 0.7.0_rc2
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-python/doublex-expects/doublex-expects-0.7.0_rc2.ebuild')
-rw-r--r--dev-python/doublex-expects/doublex-expects-0.7.0_rc2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/doublex-expects/doublex-expects-0.7.0_rc2.ebuild b/dev-python/doublex-expects/doublex-expects-0.7.0_rc2.ebuild
new file mode 100644
index 000000000000..d0ec5e614b1b
--- /dev/null
+++ b/dev-python/doublex-expects/doublex-expects-0.7.0_rc2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="Expects matchers for Doublex test doubles assertions"
+HOMEPAGE="https://github.com/jaimegildesagredo/doublex-expects"
+SRC_URI="https://github.com/jaimegildesagredo/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mamba[${PYTHON_USEDEP}] )
+"
+RDEPEND="
+ dev-python/doublex[${PYTHON_USEDEP}]
+ >=dev-python/expects-0.8.0_rc1[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ mamba || die "Tests failed under ${EPYTHON}"
+}