summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-21 17:50:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-21 20:04:57 +0100
commit5dfb48ba73476937ae67b5088b49ca65ad031c7d (patch)
tree48940d6ec4d3d31ed3d41167431db6a68d5b4cf0 /dev-python/exceptiongroup
parentdev-python/pygit2: Bump to 1.13.3 (diff)
downloadgentoo-5dfb48ba73476937ae67b5088b49ca65ad031c7d.tar.gz
gentoo-5dfb48ba73476937ae67b5088b49ca65ad031c7d.tar.bz2
gentoo-5dfb48ba73476937ae67b5088b49ca65ad031c7d.zip
dev-python/exceptiongroup: Bump to 1.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/exceptiongroup')
-rw-r--r--dev-python/exceptiongroup/Manifest1
-rw-r--r--dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/exceptiongroup/Manifest b/dev-python/exceptiongroup/Manifest
index 2f8ad0e2a5f8..d4de9b1ae807 100644
--- a/dev-python/exceptiongroup/Manifest
+++ b/dev-python/exceptiongroup/Manifest
@@ -1 +1,2 @@
DIST exceptiongroup-1.1.3.gh.tar.gz 24057 BLAKE2B c178152b92ac4079bb10614918d80f1b772f1d2c02e82fdbc19fc576c434df5f92d731116b46145ef3c3a3e57b4b899f6be11e2452a13170d27072b6b2ad74b5 SHA512 fddc52abb6b61c024c5832f6d2ed723a834c31e2bc713a3c5796581e8edbd3299d9342885cfcb5ed83ad7f7fdbb7c461ffcec354c0328a740a40d5340997d1c8
+DIST exceptiongroup-1.2.0.gh.tar.gz 27368 BLAKE2B 93ac3872fe9f9f0eab80b9e667308a8f1d06541dbfa19dda5bcbd7d9c7d6963872294b7549d88a10e0574e9db1aaa7bd39748e1237ac86e1f83dbb2ef89686d0 SHA512 eeac523fd338099dea66c5b2f7fcc070612746487be244deba8a1c731c1f23db24763dd9e35c28dfb9460b49c645f380e6858f998f95b9244dfb82f5549f159b
diff --git a/dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild b/dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild
new file mode 100644
index 000000000000..df9172779f44
--- /dev/null
+++ b/dev-python/exceptiongroup/exceptiongroup-1.2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit_scm
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Backport of PEP 654 (exception groups)"
+HOMEPAGE="
+ https://github.com/agronholm/exceptiongroup/
+ https://pypi.org/project/exceptiongroup/
+"
+# pypi sdist does not include tests as of 1.1.1
+# https://github.com/agronholm/exceptiongroup/pull/59
+SRC_URI="
+ https://github.com/agronholm/exceptiongroup/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT PSF-2.4"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV/_}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}