summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-29 09:51:39 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-29 09:51:39 +0100
commit106bb50dc02e764905f50cd542854a8eb4b97072 (patch)
tree3e8531b530e43eb93ccc39c9db642cfdf5ec7a2e /dev-python/flask-security/flask-security-1.7.5-r1.ebuild
parentdev-python/flask-script: Remove old (diff)
downloadgentoo-106bb50dc02e764905f50cd542854a8eb4b97072.tar.gz
gentoo-106bb50dc02e764905f50cd542854a8eb4b97072.tar.bz2
gentoo-106bb50dc02e764905f50cd542854a8eb4b97072.zip
dev-python/flask-security: Remove old
Package-Manager: Portage-2.3.83, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/flask-security/flask-security-1.7.5-r1.ebuild')
-rw-r--r--dev-python/flask-security/flask-security-1.7.5-r1.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/flask-security/flask-security-1.7.5-r1.ebuild b/dev-python/flask-security/flask-security-1.7.5-r1.ebuild
deleted file mode 100644
index b0e48bc30f4e..000000000000
--- a/dev-python/flask-security/flask-security-1.7.5-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_5 )
-
-inherit distutils-r1
-
-MY_PN="Flask-Security"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Simple security for Flask apps"
-HOMEPAGE="https://pythonhosted.org/Flask-Security/ https://pypi.org/project/Flask-Security/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-# tests are foobar
-RESTRICT="test"
-
-RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-0.17[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.6.1[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.1.3[${PYTHON_USEDEP}]
- >=dev-python/flask-mail-0.7.3[${PYTHON_USEDEP}]
- >=dev-python/flask-wtf-0.8[${PYTHON_USEDEP}]
- >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
- dev-python/flask-mongoengine[${PYTHON_USEDEP}]
- dev-python/bcrypt[${PYTHON_USEDEP}]
- dev-python/simplejson[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/flask-peewee[${PYTHON_USEDEP}]' 'python2*')
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- nosetests -v || die "Testing failed with ${EPYTHON}"
-}