summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-09-09 22:48:36 +0200
committerSam James <sam@gentoo.org>2024-09-09 22:08:13 +0100
commit3f214e2c9b32c03cd33f3507bd9d1db80601a4c2 (patch)
treeb2da132714ffe8e3e2f9691e7c041cf7fb265d6e /dev-python/gdb-pt-dump
parentapp-misc/binwalk: Stabilize 2.4.2 arm64, #939382 (diff)
downloadgentoo-3f214e2c9b32c03cd33f3507bd9d1db80601a4c2.tar.gz
gentoo-3f214e2c9b32c03cd33f3507bd9d1db80601a4c2.tar.bz2
gentoo-3f214e2c9b32c03cd33f3507bd9d1db80601a4c2.zip
dev-python/gdb-pt-dump: add 0.0.0_p20240401
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/gdb-pt-dump')
-rw-r--r--dev-python/gdb-pt-dump/Manifest1
-rw-r--r--dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/gdb-pt-dump/Manifest b/dev-python/gdb-pt-dump/Manifest
index b69b7da870f8..429ef6b178d7 100644
--- a/dev-python/gdb-pt-dump/Manifest
+++ b/dev-python/gdb-pt-dump/Manifest
@@ -1 +1,2 @@
DIST gdb-pt-dump-0.0.0_p20231111.gh.tar.gz 386894 BLAKE2B 31c15a7574ac37e859831e6b17d27ce47bc6aed4d3bb81a01c8492b803cd71ba28379777bd9c221c9f81585811bba4952fb8e5349104ff36e88efe3996715937 SHA512 c94cce47754b634a2fda267f715cdd7957ec0714c4ac96d6b9e20fa4cfdf6c026a3e0b351bf0e041ea0c2dbf253f547ede3d2b13b83c6316ef6222bac0e4b61b
+DIST gdb-pt-dump-0.0.0_p20240401.gh.tar.gz 406426 BLAKE2B 9b50d600df72eec81b2d146dc972a2096ce6d8a085b79360dfefc3d45a733e29008ca3986496811532e541deec46d71410191869cd9643c603a3955d683e6ff7 SHA512 bb521868ccfbae8a411bc57e067cdda227b113cb20bc97eefad77a693f66d00d20debbce51f69c8daf86128bbf938cd3304ea97992aa817a608ce65f80173e10
diff --git a/dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild b/dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild
new file mode 100644
index 000000000000..3c950733ea16
--- /dev/null
+++ b/dev-python/gdb-pt-dump/gdb-pt-dump-0.0.0_p20240401.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Examine the address space of a QEMU-based virtual machine"
+HOMEPAGE="https://github.com/martinradev/gdb-pt-dump"
+
+GDB_PT_DUMP_COMMIT="50227bda0b6332e94027f811a15879588de6d5cb"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/martinradev/gdb-pt-dump.git"
+else
+ SRC_URI="https://github.com/martinradev/gdb-pt-dump/archive/${GDB_PT_DUMP_COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/${PN}-${GDB_PT_DUMP_COMMIT}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
+"