summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 12:14:03 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 12:14:03 +0100
commit68194a6161779cba0093fb2a16be455438a2ae3e (patch)
tree6827121d5179633eedafffc6c229ecd6b82959a1 /dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
parentdev-python/numexpr: Remove redundant versions (diff)
downloadgentoo-68194a6161779cba0093fb2a16be455438a2ae3e.tar.gz
gentoo-68194a6161779cba0093fb2a16be455438a2ae3e.tar.bz2
gentoo-68194a6161779cba0093fb2a16be455438a2ae3e.zip
dev-python/google-api-python-client: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild')
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild b/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
deleted file mode 100644
index c66c66487bde..000000000000
--- a/dev-python/google-api-python-client/google-api-python-client-1.5.3.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Google API Client for Python"
-HOMEPAGE="https://github.com/google/google-api-python-client"
-SRC_URI="https://github.com/google/google-api-python-client/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
- <dev-python/httplib2-1[${PYTHON_USEDEP}]
- >=dev-python/oauth2client-2[${PYTHON_USEDEP}]
- <dev-python/oauth2client-3[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/uritemplate-0.6[${PYTHON_USEDEP}]
- <dev-python/uritemplate-1[${PYTHON_USEDEP}]
- >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
- <dev-python/six-2[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- export SKIP_GOOGLEAPICLIENT_COMPAT_CHECK=true
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbosity=3 || die
-}