summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-21 04:52:11 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-21 05:13:55 +0200
commit6d3517608e55617f51fd706f9bed1d8ba69effed (patch)
treeaed241fad1ad1bcf3e2fe0c41b53b0dbd2da8510 /dev-python/google-api-python-client
parentdev-python/mkdocs-autorefs: Bump to 1.1.0 (diff)
downloadgentoo-6d3517608e55617f51fd706f9bed1d8ba69effed.tar.gz
gentoo-6d3517608e55617f51fd706f9bed1d8ba69effed.tar.bz2
gentoo-6d3517608e55617f51fd706f9bed1d8ba69effed.zip
dev-python/google-api-python-client: Bump to 2.142.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-api-python-client')
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.142.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 31506f1b0f6e..f96e5dc19f6a 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -2,3 +2,4 @@ DIST google_api_python_client-2.138.0.tar.gz 11595036 BLAKE2B 554abf4e58264d60a5
DIST google_api_python_client-2.139.0.tar.gz 11606939 BLAKE2B 9ad0cd36a913235e8c7b5afe2f4334399deb662d2d6287a64d98b02d890368839b345dba5e64aad3c852d655e99a04f8eb6902498664c4efa3a693ae2a2c6aeb SHA512 b6235f866a402ebde20fc8cfce41ad5bd0b8034311ab5b4f1b4cc88cea03f52021ee23264a32e9577ee1fa5bcbbb07af1c4e6d5e3f85bc53c0e6760654543b34
DIST google_api_python_client-2.140.0.tar.gz 11618875 BLAKE2B 0d156fa072b302c0410f8e70681556ee146d8d8951576b1890e429b40363661d263554ad61157256feebee9a45afdf3dcdbb287b7c1dc367a6b6940ec488a645 SHA512 168e75ea734edbf0182078fad27d30f8dd56b07a8c7056973c7df99fb7faff83034901b6742aab8e03c833b73a5fd31a92455105ccc6f0f5b741fadb66715f30
DIST google_api_python_client-2.141.0.tar.gz 11652283 BLAKE2B 23209b950bb0712890f5c6b2dd0f238b8397a3084a9d61d6423b6d7275faa719d788551868037ab3c4a8ec8d0e37cff96859a1b933e395ef5feadae711c79be9 SHA512 c8d0f879ce9466e3c93e36f263ad9185bc844dae229ed1791068025dd200f21d67d0c87a5ee8ca8b6b0d71c7aad10b6a97dcfc7e7fed20017f992f5bdc7ea225
+DIST google_api_python_client-2.142.0.tar.gz 11680160 BLAKE2B 660e61509969fc6d6d5235163cdede57011150f8932bb4bfccbae19ae020367a34b9ee103b5ec788bbe22580ca60ff242bf3734ce0f81cc20a64e80d57e7628d SHA512 ede409d7f46fb06aaaf3cf2c850259cc8e7e7d2b4a8469323118f2774c31f52f9a11a8fac68d3e2ea27e9425badb5ca08c2b432321d23b6b0b460dafb0e652ce
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.142.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.142.0.ebuild
new file mode 100644
index 000000000000..58a0eb467bad
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.142.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ tests/test_discovery.py::Universe::test_client_options_universe_configured_with_mtls
+ tests/test_discovery.py::Universe::test_universe_env_var_configured_with_mtls
+ )
+
+ epytest tests
+}