summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-16 06:12:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-16 06:40:14 +0100
commit3b18b7f5dd29111d1d864e93a6a00ded77a0564f (patch)
tree04be9aa1fad609d03f0339cfef12bd5fe1521162 /dev-python/google-auth
parentdev-python/GitPython: Bump to 3.1.42 (diff)
downloadgentoo-3b18b7f5dd29111d1d864e93a6a00ded77a0564f.tar.gz
gentoo-3b18b7f5dd29111d1d864e93a6a00ded77a0564f.tar.bz2
gentoo-3b18b7f5dd29111d1d864e93a6a00ded77a0564f.zip
dev-python/google-auth: Bump to 2.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/google-auth')
-rw-r--r--dev-python/google-auth/Manifest1
-rw-r--r--dev-python/google-auth/google-auth-2.28.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/google-auth/Manifest b/dev-python/google-auth/Manifest
index 66ab67dae938..55fd84938bce 100644
--- a/dev-python/google-auth/Manifest
+++ b/dev-python/google-auth/Manifest
@@ -1 +1,2 @@
DIST google-auth-2.27.0.tar.gz 239688 BLAKE2B 3fa3c3c3da41b6337140e0ae474ab5b3a2da5aad3d18be64959c90339e03279594af97033faf406c0e76a923686b89a8f55ce5f7dff3bf3ad4510aca85189240 SHA512 a352cfced15d3e312410d382170909024d00cc27c34c3ec166af36aacf37ea9ac76b5c8bafc6e1379e2ddf3e422c27ce996474338d4efd17c21c9e79f3756994
+DIST google-auth-2.28.0.tar.gz 240460 BLAKE2B f7275d8ff1eb80871914a27a4cdcb7143d3d5de9d6217b74b2acfb64a95e7953dc076cd0d3796f81be62b174ea574a0ff7f557cc2372e475c08f095c8f299833 SHA512 b9c31ab425dc2e934443123cc5666e69ca7736e029f68b12b1a297c8818e28806671dd4ea01344213565718474182e4f2e1639f49ac408fb7913e8af4399daae
diff --git a/dev-python/google-auth/google-auth-2.28.0.ebuild b/dev-python/google-auth/google-auth-2.28.0.ebuild
new file mode 100644
index 000000000000..e044a6c75ff3
--- /dev/null
+++ b/dev-python/google-auth/google-auth-2.28.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Google Authentication Library"
+HOMEPAGE="
+ https://github.com/googleapis/google-auth-library-python/
+ https://pypi.org/project/google-auth/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ <dev-python/cachetools-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-modules-0.2.1[${PYTHON_USEDEP}]
+ >=dev-python/rsa-3.1.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/moto[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ dev-python/pyu2f[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # these are compatibility tests with oauth2client
+ # disable them to unblock removal of that package
+ tests/test__oauth2client.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}