summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-06 15:08:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-06 15:15:39 +0300
commitb8538b34595ecfc82d246004d20fe323abb130f6 (patch)
tree1afb6aeb4ac23c1644d391ecb2dbc80ae46f9702 /dev-python/grpcio-testing
parentdev-python/grpcio: add 1.41.0, enable py3.10 (diff)
downloadgentoo-b8538b34595ecfc82d246004d20fe323abb130f6.tar.gz
gentoo-b8538b34595ecfc82d246004d20fe323abb130f6.tar.bz2
gentoo-b8538b34595ecfc82d246004d20fe323abb130f6.zip
dev-python/grpcio-testing: add 1.41.0, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/grpcio-testing')
-rw-r--r--dev-python/grpcio-testing/Manifest1
-rw-r--r--dev-python/grpcio-testing/grpcio-testing-1.41.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/grpcio-testing/Manifest b/dev-python/grpcio-testing/Manifest
index 6c8e053442ed..49b0c881bff1 100644
--- a/dev-python/grpcio-testing/Manifest
+++ b/dev-python/grpcio-testing/Manifest
@@ -1 +1,2 @@
DIST grpcio-testing-1.38.1.tar.gz 16862 BLAKE2B fad99b35851e36b4e80e8d5d1ec91fd5f22e21a37596b3240aa81128fc77b73c95ce83f0d0423a047c85b9dba428e94f9a2c1681971776c1a141c756026b7ce1 SHA512 2814247be309498ef9605d630afd4bdf1843b21e89a7d6742b27107499ac73ca60c2bbcbe9b76d2be765505025e887af9a2b2159b324f10e3d85960759aba23c
+DIST grpcio-testing-1.41.0.tar.gz 16777 BLAKE2B 143b543f713c5d92d016cb428e06503fc92f33a9ae758eddae25b5d815222bff7d045d0330a148b072638adff3157b7accbc5fc0eb9c99c981499acd1916f37c SHA512 107bd368a10112cb9bfd0ea0cde8c245ac3131e7db4c14884ec9cd768cf510986dd06ed84b922df81542273951a8f25ef6b75954c3c6e5b42b3b80475508303b
diff --git a/dev-python/grpcio-testing/grpcio-testing-1.41.0.ebuild b/dev-python/grpcio-testing/grpcio-testing-1.41.0.ebuild
new file mode 100644
index 000000000000..dd036f46ba69
--- /dev/null
+++ b/dev-python/grpcio-testing/grpcio-testing-1.41.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utilities for gRPC Python"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ ~dev-python/grpcio-${PV}[${PYTHON_USEDEP}]
+ dev-python/protobuf-python[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}"