summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-09 05:55:28 +0100
committerSam James <sam@gentoo.org>2022-07-09 05:55:42 +0100
commit3b1b19426f8951b841fd391e443439a9b3597941 (patch)
tree55536656b1d156d180fca40e49ebd811038f7ca4 /dev-python/imapclient
parentdev-util/watchman: update Manifest (diff)
downloadgentoo-3b1b19426f8951b841fd391e443439a9b3597941.tar.gz
gentoo-3b1b19426f8951b841fd391e443439a9b3597941.tar.bz2
gentoo-3b1b19426f8951b841fd391e443439a9b3597941.zip
dev-python/imapclient: add 2.3.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/imapclient')
-rw-r--r--dev-python/imapclient/Manifest1
-rw-r--r--[-rwxr-xr-x]dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch0
-rw-r--r--dev-python/imapclient/imapclient-2.3.1.ebuild28
3 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/imapclient/Manifest b/dev-python/imapclient/Manifest
index 2dc9dc7037ff..67bd5e0feda5 100644
--- a/dev-python/imapclient/Manifest
+++ b/dev-python/imapclient/Manifest
@@ -1,2 +1,3 @@
DIST imapclient-2.2.0.gh.tar.gz 89505 BLAKE2B 448e8c736cd80f261c50dd7d6fe88498bf988e475f8135bf7079021d0154904741ab8af28c0ede817ec1bd8c7bd329b1c891c24e37c3466d68287afa02d636c7 SHA512 ace8f55e0f7f4dbb9127b2bbf26cce4c12dce40357cf8127aa6e377321d5156f91f913bd4d4ca57bd5b7f0c86ae5d0b7fdf352b74a6edb7d607f46aa45a144a2
DIST imapclient-2.2.0.tar.gz 89505 BLAKE2B 448e8c736cd80f261c50dd7d6fe88498bf988e475f8135bf7079021d0154904741ab8af28c0ede817ec1bd8c7bd329b1c891c24e37c3466d68287afa02d636c7 SHA512 ace8f55e0f7f4dbb9127b2bbf26cce4c12dce40357cf8127aa6e377321d5156f91f913bd4d4ca57bd5b7f0c86ae5d0b7fdf352b74a6edb7d607f46aa45a144a2
+DIST imapclient-2.3.1.gh.tar.gz 91141 BLAKE2B c4efbdb4a513277039389e13d0f86498df3bb4c466026510fba55a8cf88316a3c5b02c15215e3e40e8e0b6206e8bd4659e75b1f83ba2a905a2aaec21f8af4b48 SHA512 06a9264e8cc001b8a4a6a855032bbb9b904c94999d090c3f1bedea1ae3a16524f668eb4dfa36e7a23a0622bd9d3e83191dcc1e5e30275cb6fcb7604142e5e2a6
diff --git a/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch b/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch
index b3a12823f6a5..b3a12823f6a5 100755..100644
--- a/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch
+++ b/dev-python/imapclient/files/imapclient-2.2.0-ssl-context.patch
diff --git a/dev-python/imapclient/imapclient-2.3.1.ebuild b/dev-python/imapclient/imapclient-2.3.1.ebuild
new file mode 100644
index 000000000000..c0b4db879005
--- /dev/null
+++ b/dev-python/imapclient/imapclient-2.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="easy-to-use, pythonic, and complete IMAP client library"
+HOMEPAGE="https://github.com/mjs/imapclient"
+SRC_URI="https://github.com/mjs/imapclient/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx doc/src
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}