summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2015-12-30 09:53:53 +0100
committerIan Delaney <idella4@gentoo.org>2015-12-30 17:52:40 +0800
commitb51b86d2af4acd314ed62b2c333b7af54402341e (patch)
treeb9c0b16381b8e94bdb32fbb972102ab679644079 /dev-python/jaraco-collections
parentdev-python/jaraco-text: needed as a new dep to dev-python/irc (diff)
downloadgentoo-b51b86d2af4acd314ed62b2c333b7af54402341e.tar.gz
gentoo-b51b86d2af4acd314ed62b2c333b7af54402341e.tar.bz2
gentoo-b51b86d2af4acd314ed62b2c333b7af54402341e.zip
dev-python/jaraco-collections: needed as a new dep to dev-python/irc
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/jaraco-collections')
-rw-r--r--dev-python/jaraco-collections/Manifest1
-rw-r--r--dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild49
-rw-r--r--dev-python/jaraco-collections/metadata.xml14
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/jaraco-collections/Manifest b/dev-python/jaraco-collections/Manifest
new file mode 100644
index 000000000000..56ee04da2326
--- /dev/null
+++ b/dev-python/jaraco-collections/Manifest
@@ -0,0 +1 @@
+DIST jaraco.collections-1.3.1.tar.gz 8616 SHA256 27e3d67f94372d70be25f46a48796441ca719aedbd4a411835e71e88455bbe66 SHA512 812fbb66543e204f09f4dc35fc43888b3e8e1cbbf4a2a0e75a0589286e1ee5b303dc30b93696d8fc952bb3dddab95d8ed5ddb09ad4511ad4e12069fb87a93386 WHIRLPOOL c8730e3bd1eb1950b523ce62e31f7e2d2fd46bacdcacd7c57b9b55f95cff51e025e47813af1777d362f83401822a4015fdd386e977bbbd26f9c1a130ff7aa65a
diff --git a/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild b/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild
new file mode 100644
index 000000000000..e54b66f95192
--- /dev/null
+++ b/dev-python/jaraco-collections/jaraco-collections-1.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Models and classes to supplement the stdlib collections module"
+HOMEPAGE="https://github.com/jaraco/jaraco.collections"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PDEPEND="dev-python/jaraco-text[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/jaraco-classes[${PYTHON_USEDEP}]
+dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ if use test; then
+ if has_version "${CATEGORY}/${PN}"; then
+ die "Ensure $PN is not already installed or the test suite will fail"
+ elif ! has_version "dev-python/jaraco-text"; then
+ die "Ensure dev-python/jaraco-text is installed or the test suite will fail"
+ fi
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
+}
diff --git a/dev-python/jaraco-collections/metadata.xml b/dev-python/jaraco-collections/metadata.xml
new file mode 100644
index 000000000000..18440792aa47
--- /dev/null
+++ b/dev-python/jaraco-collections/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jaraco.collections</remote-id>
+ <remote-id type="github">jaraco/jaraco.collections</remote-id>
+ </upstream>
+</pkgmetadata>