summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-19 07:30:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-19 07:46:12 +0100
commit5edcda36d4a5341e4d7dd396f69246179d5f9f0d (patch)
tree8f9ac3bfd15f9088160d692e5144b7fa4bb8e7f7 /dev-python/keyring
parentdev-python/autobahn: Bump to 22.12.1 (diff)
downloadgentoo-5edcda36d4a5341e4d7dd396f69246179d5f9f0d.tar.gz
gentoo-5edcda36d4a5341e4d7dd396f69246179d5f9f0d.tar.bz2
gentoo-5edcda36d4a5341e4d7dd396f69246179d5f9f0d.zip
dev-python/keyring: Bump to 23.13.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-23.13.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 638553659668..5b83fa420619 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1 +1,2 @@
DIST keyring-23.11.0.gh.tar.gz 47229 BLAKE2B cb5f4a771bc94db058d5783e6bcfc84a29359d8445f55a38b125fe5e751a7e13ce54533fcdf7ab47b50f5fb37a20858c4113ad7ec683b2123f136a7059763bff SHA512 8f200455229ef944729bab557845b2e4220fdd5146d3610105c907fe14ae4358ce85fab0c63c2a0598968871fc01e8b564c8e4d436930f3d39f11e93ae0b209c
+DIST keyring-23.13.1.gh.tar.gz 49199 BLAKE2B 46ac7cb3237c7e0a061e9c4c30dba02d9a9c92d377f3db1b79b1c9bc4c5b8b866ffbda8354bbe5848a9db4c6834aec1c0b36f75d5c540ccc29ab71bd6adf30f4 SHA512 b0fc17157536178bba3a8f27f152a1cba497bc9ba2fc73d29ac9d8e61a2be51bdb0dea100eef9ab59979a9b0f8c8d15ca222e5fdc2c7d06d202955b18f21bf24
diff --git a/dev-python/keyring/keyring-23.13.1.ebuild b/dev-python/keyring/keyring-23.13.1.ebuild
new file mode 100644
index 000000000000..d7372edce760
--- /dev/null
+++ b/dev-python/keyring/keyring-23.13.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+SRC_URI="
+ https://github.com/jaraco/keyring/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="PSF-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.4[${PYTHON_USEDEP}]
+ ' 3.8 3.9 3.10 3.11)
+ $(python_gen_cond_dep '
+ dev-python/importlib_resources
+ ' 3.8)
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+)
+
+EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+)