summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 16:26:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 16:43:42 +0100
commit2ed014cf213253203981ba88c45cd2f341100e6c (patch)
tree59025cabe7cb6fcb7af73437ba6e3e1fc80149d0 /dev-python/logutils
parentdev-python/liblarch: Switch to PEP 517 build (diff)
downloadgentoo-2ed014cf213253203981ba88c45cd2f341100e6c.tar.gz
gentoo-2ed014cf213253203981ba88c45cd2f341100e6c.tar.bz2
gentoo-2ed014cf213253203981ba88c45cd2f341100e6c.zip
dev-python/logutils: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/logutils')
-rw-r--r--dev-python/logutils/logutils-0.3.5-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/logutils/logutils-0.3.5-r1.ebuild b/dev-python/logutils/logutils-0.3.5-r1.ebuild
new file mode 100644
index 000000000000..75325842ddcd
--- /dev/null
+++ b/dev-python/logutils/logutils-0.3.5-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="The logutils package provides a set of handlers for the Python standard"
+HOMEPAGE="https://bitbucket.org/vinay.sajip/logutils"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests setup.py