summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-19 11:19:53 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-02-19 12:12:19 +0100
commit7827bf1ca94eb96cf3914c2bb7881bc71331814e (patch)
treeb3edd5abaf8e22d38ac414dad59238bf4d1cd5ab /dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
parentdev-python/mkdocs_pymdownx_material_extras: add version 1.6 (diff)
downloadgentoo-7827bf1ca94eb96cf3914c2bb7881bc71331814e.tar.gz
gentoo-7827bf1ca94eb96cf3914c2bb7881bc71331814e.tar.bz2
gentoo-7827bf1ca94eb96cf3914c2bb7881bc71331814e.zip
dev-python/mkdocs-git-authors-plugin: add version 0.6.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild')
-rw-r--r--dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
new file mode 100644
index 000000000000..9351c88694ad
--- /dev/null
+++ b/dev-python/mkdocs-git-authors-plugin/mkdocs-git-authors-plugin-0.6.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{8..10} )
+
+DOCS_BUILDER="mkdocs"
+DOCS_DEPEND="dev-python/mkdocs-material"
+
+inherit distutils-r1 docs
+
+DESCRIPTION="Mkdocs plugin to display git authors of a page"
+HOMEPAGE="
+ https://github.com/timvink/mkdocs-git-authors-plugin/
+ https://pypi.org/project/mkdocs-git-authors-plugin/
+"
+SRC_URI="https://github.com/timvink/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/GitPython[${PYTHON_USEDEP}]
+ >=dev-python/mkdocs-1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ dev-python/mkdocs-git-revision-date-localized-plugin[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+ doc? ( dev-vcs/git )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # mkdocs-git-authors tests need git repo
+ if use test || use doc; then
+ git init -q || die
+ git config --global user.email "you@example.com" || die
+ git config --global user.name "Your Name" || die
+ git add . || die
+ git commit -qm 'init' || die
+ fi
+
+ distutils-r1_python_prepare_all
+}