summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-22 13:49:11 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-22 13:50:43 +0200
commit0ebb515b6e2132c4f89b1ce181f22d1bb9b21a40 (patch)
tree61db451d0056c5c75a9b424d3317c276f72a43ef /dev-python/msgpack
parentapp-backup/borgbackup: Remove old (diff)
downloadgentoo-0ebb515b6e2132c4f89b1ce181f22d1bb9b21a40.tar.gz
gentoo-0ebb515b6e2132c4f89b1ce181f22d1bb9b21a40.tar.bz2
gentoo-0ebb515b6e2132c4f89b1ce181f22d1bb9b21a40.zip
dev-python/msgpack: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/Manifest2
-rw-r--r--dev-python/msgpack/msgpack-0.6.2.ebuild38
-rw-r--r--dev-python/msgpack/msgpack-1.0.3-r1.ebuild45
-rw-r--r--dev-python/msgpack/msgpack-1.0.3.ebuild38
4 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/msgpack/Manifest b/dev-python/msgpack/Manifest
index 2d9eb9aaaece..a992da3dafd7 100644
--- a/dev-python/msgpack/Manifest
+++ b/dev-python/msgpack/Manifest
@@ -1,3 +1 @@
-DIST msgpack-0.6.2.tar.gz 119062 BLAKE2B 6b20a0d31b811ae66e66dbfaacec6f0cf2152b2937423b78f3e6244bfa49c87767788c5ee1db41b9020801b8777a4c15b1fe1853182718adf622bc7e1bff858e SHA512 95b92e3d35e0500dd4256d18bf76e586e57cc66319b4459ac5daef599277a5049177a89ad86e291dbdc4c7a918901a89d9218353ddc4a7d0b399e8a98afef363
-DIST msgpack-1.0.3.tar.gz 123830 BLAKE2B 308af03206fef18edb0acd3c1d91ccd28385731c02cb930e8f64786bbcd8925510cf4ca0b924830b84fd6eaa7edf91e6a43f79c77d856651768eeaa1ab8cf855 SHA512 1569e42c6499c60458a63aa722b5c7e3dc817e38ae4bed2dc8199dc1bcbc36ff876e055b046b4f6063b5606036ae9238080c05be1e09a61a34e7f97fd5031fcd
DIST msgpack-1.0.4.tar.gz 128053 BLAKE2B fcbaafbea57f87c949a43a6bd6f6507eb3a07ac5e4a9c44fabfbb7c07849f1edabb8dadcd99a547fed32bce0f900f965368c4ee744acd4e850cad5c27022f463 SHA512 dcd59bf77408acf7171bdcc46c4d6bf875d36e80b216b7721544855e6c2b20be469415ee768b2195e74fe4650621ee6bfaa7897e709ac0d8d59cdb30772cb90b
diff --git a/dev-python/msgpack/msgpack-0.6.2.ebuild b/dev-python/msgpack/msgpack-0.6.2.ebuild
deleted file mode 100644
index f82e46a6cd93..000000000000
--- a/dev-python/msgpack/msgpack-0.6.2.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="https://msgpack.org
- https://github.com/msgpack/msgpack-python/
- https://pypi.org/project/msgpack/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc x86"
-IUSE="+native-extensions test"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- native-extensions? (
- $(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*')
- )
- test? ( dev-python/six[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Remove pre-generated cython files
- rm msgpack/{_packer,_unpacker,_cmsgpack}.pyx || die
-
- if ! use native-extensions ; then
- sed -i -e "/have_cython/s:True:False:" setup.py || die
- fi
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/msgpack/msgpack-1.0.3-r1.ebuild b/dev-python/msgpack/msgpack-1.0.3-r1.ebuild
deleted file mode 100644
index 0235db540f16..000000000000
--- a/dev-python/msgpack/msgpack-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="
- https://msgpack.org/
- https://github.com/msgpack/msgpack-python/
- https://pypi.org/project/msgpack/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
-IUSE="+native-extensions"
-
-# extension code is relying on CPython implementation details
-BDEPEND="
- native-extensions? (
- $(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*')
- )
- test? (
- dev-python/six[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Remove pre-generated cython files
- rm msgpack/_cmsgpack.cpp || die
-
- if ! use native-extensions ; then
- sed -i -e "/have_cython/s:True:False:" setup.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/msgpack/msgpack-1.0.3.ebuild b/dev-python/msgpack/msgpack-1.0.3.ebuild
deleted file mode 100644
index e5b2793b5bb3..000000000000
--- a/dev-python/msgpack/msgpack-1.0.3.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1
-
-DESCRIPTION="MessagePack (de)serializer for Python"
-HOMEPAGE="https://msgpack.org
- https://github.com/msgpack/msgpack-python/
- https://pypi.org/project/msgpack/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ~ppc64 ~riscv x86 ~x64-macos"
-IUSE="+native-extensions"
-
-# extension code is relying on CPython implementation details
-BDEPEND="
- native-extensions? (
- $(python_gen_cond_dep '>=dev-python/cython-0.16[${PYTHON_USEDEP}]' 'python*')
- )
- test? ( dev-python/six[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Remove pre-generated cython files
- rm msgpack/_cmsgpack.cpp || die
-
- if ! use native-extensions ; then
- sed -i -e "/have_cython/s:True:False:" setup.py || die
- fi
- distutils-r1_python_prepare_all
-}