summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-09 08:08:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-09 09:09:38 +0100
commit4287e9a2b544e14950e66c201c98888492906f37 (patch)
tree56d3f591a315a6fa135df37bd38adc37eab59277 /dev-python/packaging
parentdev-python/cachetools: Bump to 5.2.1 (diff)
downloadgentoo-4287e9a2b544e14950e66c201c98888492906f37.tar.gz
gentoo-4287e9a2b544e14950e66c201c98888492906f37.tar.bz2
gentoo-4287e9a2b544e14950e66c201c98888492906f37.zip
dev-python/packaging: Bump to 23.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/packaging')
-rw-r--r--dev-python/packaging/Manifest1
-rw-r--r--dev-python/packaging/packaging-23.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/packaging/Manifest b/dev-python/packaging/Manifest
index c6cdfbeb954d..0f7ae56efab7 100644
--- a/dev-python/packaging/Manifest
+++ b/dev-python/packaging/Manifest
@@ -1,2 +1,3 @@
DIST packaging-21.3.gh.tar.gz 80471 BLAKE2B a16ba1e74f0c868816131a7cb07b7aa0c14760cf3ad4c3d6737ac30ef99276c33b1f018d29e710f28e8d0cfb0e3e6b91e375d1d17e2b7ec6302164377cd503d0 SHA512 8960deacda26877b73d98a3b632e760e902a16ec7a04707f84044980e4d4fb33e4f584db115c9008066aa876079f28633bafe37fbd5ce9a23830b6b89eb4ae7a
DIST packaging-22.0.gh.tar.gz 83340 BLAKE2B 6f8e36c1bed71d4d5902fb833a7c011f3eac5e5e00f9e73a7258bbb6c79cfd30c6c175ad5778c5a5dd88bc275a66f69448ec59937159553d229f93510e189d41 SHA512 2189dec11dd9fd78a6d816bda08f881e5aa54fde09d51450ceb460a37ba87231fcfdb5ad4f58d262face44dfb0f1c4b420f759491008f8c26cef7e8317c414a8
+DIST packaging-23.0.gh.tar.gz 84318 BLAKE2B b600fc124e368ce583e16c3f4ee478e5774a830818884ff29c797410675c206b37e3cbac8e9ddd724b40ce53c00b1f0b6a58a9dacc1988e3bf59165b656b134b SHA512 5dd2f4a596e5a1ed01b461a37e063573f5ae08e181df40377a167fe2483205b3d965e10dc403cd173d0f87e0bdcae3cde05bd39024783fbe44541d0f777d94de
diff --git a/dev-python/packaging/packaging-23.0.ebuild b/dev-python/packaging/packaging-23.0.ebuild
new file mode 100644
index 000000000000..4a743b76e5a6
--- /dev/null
+++ b/dev-python/packaging/packaging-23.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="
+ https://github.com/pypa/packaging/
+ https://pypi.org/project/packaging/"
+SRC_URI="
+ https://github.com/pypa/packaging/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/pyparsing-3.0.7-r1[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest --capture=no
+}