summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-28 16:39:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-28 16:40:30 +0200
commit020e0ec4f8b432f4a1809aa9ea0a0718d739418d (patch)
tree348f8cf72ad8b5887cbe12cf19e296819f6bcb40 /dev-python/parameterized
parentdev-python/furo: Remove old (diff)
downloadgentoo-020e0ec4f8b432f4a1809aa9ea0a0718d739418d.tar.gz
gentoo-020e0ec4f8b432f4a1809aa9ea0a0718d739418d.tar.bz2
gentoo-020e0ec4f8b432f4a1809aa9ea0a0718d739418d.zip
dev-python/parameterized: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parameterized')
-rw-r--r--dev-python/parameterized/Manifest1
-rw-r--r--dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch101
-rw-r--r--dev-python/parameterized/parameterized-0.8.1-r2.ebuild35
3 files changed, 0 insertions, 137 deletions
diff --git a/dev-python/parameterized/Manifest b/dev-python/parameterized/Manifest
index bb27ab2f92d5..989a4b866dc2 100644
--- a/dev-python/parameterized/Manifest
+++ b/dev-python/parameterized/Manifest
@@ -1,2 +1 @@
-DIST parameterized-0.8.1.tar.gz 23936 BLAKE2B 3d36b049071907f66ef17dcae0ef9480210344f2466744b2bee8e964f46e2553411a07b233fab032d1acbc2523dc32890bc5e6e4ffc5b37d1fee3f0db3a70cbb SHA512 ad6e31b2bb27623bf070ee5c30686a5bd6a531bc71602f77ca6aa01a77fc246caaacca121098dcbe13b1a174cdcfafa6545bf6e62f6a5337a647821c02fac64a
DIST parameterized-0.9.0.tar.gz 24351 BLAKE2B 3b0fb1c0a788f702cba74b67868fbd179e4912b518646f6a7d0d136f54b515d2546d27ad1fd14a03c128a8b53d42165a4ef9f8f434965483af24f69c3e406b25 SHA512 2c1c97a841db631608e0a9fcd93fa1af819aa288538851e0c771b56ba0bb27fb682ac3a09fcdb33e57162926d1e8fae452f7bab9384d0c40bec9a03ab3d6b126
diff --git a/dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch b/dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch
deleted file mode 100644
index 45b86d8a13af..000000000000
--- a/dev-python/parameterized/files/parameterized-0.8.1-nose-to-pytest.patch
+++ /dev/null
@@ -1,101 +0,0 @@
-diff --git a/parameterized/test.py b/parameterized/test.py
-index f98d865..ede7689 100644
---- a/parameterized/test.py
-+++ b/parameterized/test.py
-@@ -2,8 +2,8 @@
-
- import inspect
- import mock
-+import pytest
- from unittest import TestCase
--from nose.tools import assert_equal, assert_raises
-
- from .parameterized import (
- PY3, PY2, parameterized, param, parameterized_argument_value_pairs,
-@@ -91,7 +91,7 @@ if not PYTEST:
-
- @parameterized([(1, ), (2, )])
- def test_setup(self, count, *a):
-- assert_equal(self.actual_order, "setup %s" %(count, ))
-+ assert self.actual_order == "setup %s" %(count, )
- missing_tests.remove("test_setup(%s)" %(self.actual_order, ))
-
-
-@@ -235,9 +235,9 @@ class TestParamerizedOnTestCase(TestCase):
- frame_locals = frame[0].f_locals
- nose_test_method_name = frame_locals['a'][0]._testMethodName
- expected_name = "test_on_TestCase2_custom_name_" + str(foo)
-- assert_equal(nose_test_method_name, expected_name,
-- "Test Method name '%s' did not get customized to expected: '%s'" %
-- (nose_test_method_name, expected_name))
-+ assert nose_test_method_name == expected_name, \
-+ "Test Method name '%s' did not get customized to expected: '%s'" % \
-+ (nose_test_method_name, expected_name)
- missing_tests.remove("%s(%r, bar=%r)" %(expected_name, foo, bar))
-
-
-@@ -259,7 +259,7 @@ class TestParameterizedExpandDocstring(TestCase):
- actual_docstring = test_method.__doc__
- if rstrip:
- actual_docstring = actual_docstring.rstrip()
-- assert_equal(actual_docstring, expected_docstring)
-+ assert actual_docstring == expected_docstring
-
- @parameterized.expand([param("foo")],
- doc_func=lambda f, n, p: "stuff")
-@@ -335,7 +335,7 @@ def test_helpful_error_on_empty_iterable_input():
-
- def test_skip_test_on_empty_iterable():
- func = parameterized([], skip_on_empty=True)(lambda: None)
-- assert_raises(SkipTest, func)
-+ pytest.raises(SkipTest, func)
-
-
- def test_helpful_error_on_empty_iterable_input_expand():
-@@ -366,10 +366,6 @@ def test_helpful_error_on_non_iterable_input():
- raise AssertionError("Expected exception not raised")
-
-
--def tearDownModule():
-- missing = sorted(list(missing_tests))
-- assert_equal(missing, [])
--
- def test_old_style_classes():
- if PY3:
- raise SkipTest("Py3 doesn't have old-style classes")
-@@ -418,7 +414,7 @@ class TestOldStyleClass:
- def test_parameterized_argument_value_pairs(func_params, p, expected):
- helper = eval("lambda %s: None" %(func_params, ))
- actual = parameterized_argument_value_pairs(helper, p)
-- assert_equal(actual, expected)
-+ assert actual == expected
-
-
- @parameterized([
-@@ -428,7 +424,7 @@ def test_parameterized_argument_value_pairs(func_params, p, expected):
- (123456789, "12...89", 4),
- ])
- def test_short_repr(input, expected, n=6):
-- assert_equal(short_repr(input, n=n), expected)
-+ assert short_repr(input, n=n) == expected
-
- @parameterized([
- ("foo", ),
-@@ -442,7 +438,7 @@ cases_over_10 = [(i, i+1) for i in range(11)]
-
- @parameterized(cases_over_10)
- def test_cases_over_10(input, expected):
-- assert_equal(input, expected-1)
-+ assert input == expected-1
-
-
- @parameterized_class(("a", "b", "c"), [
-@@ -461,7 +457,7 @@ class TestParameterizedClass(TestCase):
-
- def _assertions(self, test_name):
- assert hasattr(self, "a")
-- assert_equal(self.b + self.c, 3)
-+ assert self.b + self.c == 3
- missing_tests.remove("%s:%s(%r, %r, %r)" %(
- self.__class__.__name__,
- test_name,
diff --git a/dev-python/parameterized/parameterized-0.8.1-r2.ebuild b/dev-python/parameterized/parameterized-0.8.1-r2.ebuild
deleted file mode 100644
index dfdd966aed8f..000000000000
--- a/dev-python/parameterized/parameterized-0.8.1-r2.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Parameterized testing with any Python test framework"
-HOMEPAGE="
- https://github.com/wolever/parameterized/
- https://pypi.org/project/parameterized/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-nose-to-pytest.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- epytest parameterized/test.py
-}