summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-12 08:23:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-12 08:25:04 +0200
commita477e9c37cbdd480a81a67e7ea636527e5907286 (patch)
treea29daa693aa44c7978e56e615f91719008aead22 /dev-python/pyaudio
parentsys-apps/darwin-miscutils: fix build with clang (diff)
downloadgentoo-a477e9c37cbdd480a81a67e7ea636527e5907286.tar.gz
gentoo-a477e9c37cbdd480a81a67e7ea636527e5907286.tar.bz2
gentoo-a477e9c37cbdd480a81a67e7ea636527e5907286.zip
dev-python/pyaudio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyaudio')
-rw-r--r--dev-python/pyaudio/pyaudio-0.2.13.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/pyaudio/pyaudio-0.2.13.ebuild b/dev-python/pyaudio/pyaudio-0.2.13.ebuild
deleted file mode 100644
index db5c93dc6ded..000000000000
--- a/dev-python/pyaudio/pyaudio-0.2.13.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-PYPI_NO_NORMALIZE=1
-PYPI_PN="PyAudio"
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python bindings for PortAudio"
-HOMEPAGE="http://people.csail.mit.edu/hubert/pyaudio/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# Tests work if you have the correct HW device(s) to test. 0.2.11-r1.
-RESTRICT="test"
-
-RDEPEND="media-libs/portaudio"
-DEPEND="${RDEPEND}"
-BDEPEND="test? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-
-distutils_enable_sphinx sphinx
-distutils_enable_tests unittest
-
-python_test() {
- elog "These tests require an OS loopback sound device that forwards audio"
- elog "output, generated by PyAudio for playback, and forwards it to an input"
- elog "device, which PyAudio can record and verify against a test signal."
-
- cd tests || die
- # pyaudio_tests have very complicated runtime requirements, therefore skipping them.
- "${EPYTHON}" -m unittest error_tests -v || die "Tests fail with ${EPYTHON}"
-}