summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2017-01-02 18:47:38 +0100
committerTobias Klausmann <klausman@gentoo.org>2017-01-02 18:47:38 +0100
commit522f3f78b9ed32912ddb4c788e698f111cc14d84 (patch)
tree52c779d832da85416b527b842d02aee0432ed17c /dev-python/pycodestyle
parentapp-emulation/wine: Apply flex263 patch to all available ebuilds (diff)
downloadgentoo-522f3f78b9ed32912ddb4c788e698f111cc14d84.tar.gz
gentoo-522f3f78b9ed32912ddb4c788e698f111cc14d84.tar.bz2
gentoo-522f3f78b9ed32912ddb4c788e698f111cc14d84.zip
dev-python/pycodestyle: Bump to 2.2.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/pycodestyle')
-rw-r--r--dev-python/pycodestyle/Manifest1
-rw-r--r--dev-python/pycodestyle/pycodestyle-2.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pycodestyle/Manifest b/dev-python/pycodestyle/Manifest
index fb7016ee8958..76da824035fb 100644
--- a/dev-python/pycodestyle/Manifest
+++ b/dev-python/pycodestyle/Manifest
@@ -1,2 +1,3 @@
DIST pycodestyle-2.0.0.tar.gz 81701 SHA256 37f0420b14630b0eaaf452978f3a6ea4816d787c3e6dcbba6fb255030adae2e7 SHA512 c003a75bb8873d8ec09cbaf7391c75ebd4739eeab518bbea03c8b2cdc18839773190352166ded78d32992adb56895ee1502003bca11b2d63676c10facb879ac8 WHIRLPOOL 3f162936ea03c8bcd2ba7adbcb77c3d8e44549090875719c888a9fbd86bb9cbf16d4378ffc1c2f28050253520aa86753172816429bc530bc074a2f8fd3e88613
DIST pycodestyle-2.1.0.tar.gz 85519 SHA256 5b540e4f19b4938c082cfd13f5d778d1ad2308b337abbc687ab9335233f5f3e2 SHA512 901025813884612a04a1f37d2197a7757a050cb38f0dcbff7602b636ad22ae73e943d9b6a5028feda3bec9e55eca91064ace0416ffab8ea0c1721c50dd5c2673 WHIRLPOOL edf365450a7e3440fc5302cef220817fad67832890f72624a5397f8fa69f4e9ff522f7b041788d5852e7875dc707d6b8bb94f481accfcf138c62a0efbaa891dd
+DIST pycodestyle-2.2.0.tar.gz 85811 SHA256 df81dc3293e0123e2e8d1f2aaf819600e4ae287d8b3af8b72181af50257e5d9a SHA512 19c925158d6d0fa704f58387585aa4a618c4973d9f6e99a7831d9a41cb7886a4f1fec8b696162787a84dc575adb6e1cc253fb4af31252ae9cff0ced4b066c346 WHIRLPOOL 49421e7a3a18ce6fa5959fbd22c68022eeef54949fe54ae2c4cc8e4e3c7a1e3356066ae793e4468f8716d0edaffb7c4714c5cdf7750906d533dd5c010574ee4e
diff --git a/dev-python/pycodestyle/pycodestyle-2.2.0.ebuild b/dev-python/pycodestyle/pycodestyle-2.2.0.ebuild
new file mode 100644
index 000000000000..c1734c22d24e
--- /dev/null
+++ b/dev-python/pycodestyle/pycodestyle-2.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python style guide checker (fka pep8)"
+HOMEPAGE="https://pypi.python.org/pypi/pycodestyle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --statistics pycodestyle.py || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py -v --testsuite=testsuite || die
+ PYTHONPATH="${S}" "${PYTHON}" pycodestyle.py --doctest -v || die
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}