summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-03 08:54:58 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-03 09:23:58 +0100
commitf0dcd7ffbb36cdc555884cca1bace5180371c30c (patch)
tree1008aa943bb2ddaed5f2c960365e52529c79395b /dev-python/pycryptodomex
parentdev-python/pycryptodome: Bump to 3.9.9 (diff)
downloadgentoo-f0dcd7ffbb36cdc555884cca1bace5180371c30c.tar.gz
gentoo-f0dcd7ffbb36cdc555884cca1bace5180371c30c.tar.bz2
gentoo-f0dcd7ffbb36cdc555884cca1bace5180371c30c.zip
dev-python/pycryptodomex: Bump to 3.9.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pycryptodomex')
-rw-r--r--dev-python/pycryptodomex/Manifest1
-rw-r--r--dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pycryptodomex/Manifest b/dev-python/pycryptodomex/Manifest
index d518c14e1e23..27d3092aeaf7 100644
--- a/dev-python/pycryptodomex/Manifest
+++ b/dev-python/pycryptodomex/Manifest
@@ -1 +1,2 @@
+DIST pycryptodome-3.9.9.tar.gz 15551299 BLAKE2B ac89bcc2bbe707cb2a9cf2496a2eb74ff5685f11017d60d67558de7ac6cad5c24c43b4074bff01e99378d7c88462e88e88f363c5329fb800e1a7872ad8a34dab SHA512 a1aad4d52256220fe3d5d7f399c2c5e7338d6eb88058da0571fe1c686d74d33ff4bc1c275d4b9373e0ff22f4ddcded75a25387e76fc65047f8612f8856c1bd4d
DIST pycryptodomex-3.9.8.tar.gz 15633485 BLAKE2B 3d7b8a74d2f7cc0f47c73f3f3d1dcf13c8b9feb9f2f532dc48751c4a73915aa081ecf273a81731076070f054f5b2037a5eba9054ca71e549aad18ed0c3148c74 SHA512 bcc5fb27a89c00e6348eacc744a23d687d0b308d5c8ad8f6d955fe2b9e84288a592206336e7fef699800948f8ea7b1ac06d2bec60df0b9ff0fa32d0a05380869
diff --git a/dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild b/dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild
new file mode 100644
index 000000000000..b3b8e7593c3d
--- /dev/null
+++ b/dev-python/pycryptodomex/pycryptodomex-3.9.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_P=${P/x/}
+DESCRIPTION="A self-contained cryptographic library for Python"
+HOMEPAGE="https://www.pycryptodome.org
+ https://github.com/Legrandin/pycryptodome/
+ https://pypi.org/project/pycryptodomex/"
+SRC_URI="
+ https://github.com/Legrandin/pycryptodome/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2 Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="
+ dev-libs/gmp:0"
+BDEPEND="
+ virtual/python-cffi[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${DEPEND}
+ ${BDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/pycryptodome-3.9.4-parallel-make.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ # parallel make fixes
+ # Multiple targets were compiling the same file, setuptools doesn't
+ # understand this and you get race conditions where a file gets
+ # overwritten while it's linking. This makes the files look like separate
+ # files so this race won't happen
+ ln src/blowfish.c src/blowfish_eks.c || die
+ ln src/mont.c src/mont_math.c || die
+
+ # create the magic file to build cryptodomex from the sources
+ echo > .separate_namespace || die
+
+ distutils-r1_python_prepare_all
+}