summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-22 11:41:57 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-22 11:42:49 +0200
commite2b572bc0e69a2c6dd78fd69fda542048bdb8fcc (patch)
tree4a14534b5e72563dab9320d1d7a52533d2bf9d8b /dev-python/pyh2o
parentdev-python/pyh2o: Enable tests, port to py3.9 (diff)
downloadgentoo-e2b572bc0e69a2c6dd78fd69fda542048bdb8fcc.tar.gz
gentoo-e2b572bc0e69a2c6dd78fd69fda542048bdb8fcc.tar.bz2
gentoo-e2b572bc0e69a2c6dd78fd69fda542048bdb8fcc.zip
dev-python/pyh2o: Add initial version (v1)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyh2o')
-rw-r--r--dev-python/pyh2o/Manifest1
-rw-r--r--dev-python/pyh2o/pyh2o-1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/pyh2o/Manifest b/dev-python/pyh2o/Manifest
new file mode 100644
index 000000000000..8f5b4245b529
--- /dev/null
+++ b/dev-python/pyh2o/Manifest
@@ -0,0 +1 @@
+DIST pyh2o-1.tar.gz 7327 BLAKE2B 9d6b308d17dd799e2c83a191c346a3d78fc0a097de2a2fd5cb6277a1525992aa18f6c6b61b2c2503ae4a9e7ddd3575e092aef77a0e84223a5a2c702c0a808f1d SHA512 529fa4d8e9c477346fcbd23d7172d41de96789797f0e1ad0557f4c0bdaea8a519a8e8735845d0080cf171182874ce0819e76357ca7c7db1d62a9544f907095db
diff --git a/dev-python/pyh2o/pyh2o-1.ebuild b/dev-python/pyh2o/pyh2o-1.ebuild
new file mode 100644
index 000000000000..f8392f678f6c
--- /dev/null
+++ b/dev-python/pyh2o/pyh2o-1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API for sci-libs/libh2o"
+HOMEPAGE="https://github.com/mgorny/pyh2o/"
+SRC_URI="
+ https://github.com/mgorny/pyh2o/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=sci-libs/libh2o-0.2.1:="
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest