summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-16 04:20:20 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-16 04:20:20 +0100
commit1ffc8629f725d906af8099a52a61855e7458b9f3 (patch)
tree03653730d4e4e07f40a05bd6083d872c08a8e3bf /dev-python/pykka
parentdev-python/pykka: Remove old (diff)
downloadgentoo-1ffc8629f725d906af8099a52a61855e7458b9f3.tar.gz
gentoo-1ffc8629f725d906af8099a52a61855e7458b9f3.tar.bz2
gentoo-1ffc8629f725d906af8099a52a61855e7458b9f3.zip
dev-python/pykka: Bump to 4.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pykka')
-rw-r--r--dev-python/pykka/Manifest1
-rw-r--r--dev-python/pykka/pykka-4.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pykka/Manifest b/dev-python/pykka/Manifest
index 79a1bd99df8a..9755bd818b3b 100644
--- a/dev-python/pykka/Manifest
+++ b/dev-python/pykka/Manifest
@@ -1 +1,2 @@
DIST pykka-4.1.1.gh.tar.gz 48728 BLAKE2B 4c3f0bf5454c6af04a91ebecc562e34dad257f61cca1aa20e11deea6fb524d0fa1bb86d4dd0829fe8392f57c6fd6c49b1b50abb74f08b77bccf4219d91abb5f7 SHA512 99f8738dbd0a4172e9c8a2cdbfe36335e349f8b0e421ab53ad2869e4250e6c03e69b89eea30e05c015a0203e0e6191b421f23061aa3aab869bb4383cc6ed0d49
+DIST pykka-4.1.2.gh.tar.gz 48738 BLAKE2B d6b6695a6c6482540ee5362752544753f5baaadbd888103ff13f025c5870304200cb3615d986c615b70b239d6c8710515fe9d974c765939190bd8b1abcdf3d0a SHA512 07ce084484abb56dd89399252e93a05e9f3e08b3ca023f751700a2cc99f7cb52a926c95b158c7208096bdfc250831aa1c340f2df04cbff5b159b329bb66f1c8c
diff --git a/dev-python/pykka/pykka-4.1.2.ebuild b/dev-python/pykka/pykka-4.1.2.ebuild
new file mode 100644
index 000000000000..b870fe37c451
--- /dev/null
+++ b/dev-python/pykka/pykka-4.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of the actor model"
+HOMEPAGE="
+ https://pykka.org/en/latest/
+ https://github.com/jodal/pykka/
+ https://pypi.org/project/pykka/
+"
+SRC_URI="
+ https://github.com/jodal/pykka/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest