summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:41:54 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:59 +0100
commit41afa92b72b5113aab5ce2636362a108ae0594db (patch)
tree01ca9f95031d8550b4c8caea66d6596899a23af3 /dev-python/pyspectrum2
parentdev-python/mpdlcd: drop 0.5.2 (diff)
downloadgentoo-41afa92b72b5113aab5ce2636362a108ae0594db.tar.gz
gentoo-41afa92b72b5113aab5ce2636362a108ae0594db.tar.bz2
gentoo-41afa92b72b5113aab5ce2636362a108ae0594db.zip
dev-python/pyspectrum2: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python/pyspectrum2')
-rw-r--r--dev-python/pyspectrum2/pyspectrum2-0.2.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyspectrum2/pyspectrum2-0.2.0-r1.ebuild b/dev-python/pyspectrum2/pyspectrum2-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..47099a95ccdc
--- /dev/null
+++ b/dev-python/pyspectrum2/pyspectrum2-0.2.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS="bdepend"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Implements a protobuf-based interface for Spectrum2 python-based backends"
+HOMEPAGE="https://github.com/stv0g/pyspectrum2"
+SRC_URI="https://github.com/stv0g/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="dev-python/protobuf-python[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ python_optimize
+}