summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-27 08:25:25 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-27 08:43:19 +0300
commit8fd1c67a64012976b3cfecf7e744fb791d28d1a2 (patch)
tree31a0cce5f1b636fd41b798ecc3c39a3476ed7de2 /dev-python/pytest-flakes
parentapp-arch/libarchive: x86 stable wrt bug #810523 (diff)
downloadgentoo-8fd1c67a64012976b3cfecf7e744fb791d28d1a2.tar.gz
gentoo-8fd1c67a64012976b3cfecf7e744fb791d28d1a2.tar.bz2
gentoo-8fd1c67a64012976b3cfecf7e744fb791d28d1a2.zip
dev-python/pytest-flakes: add 4.0.3, enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-flakes')
-rw-r--r--dev-python/pytest-flakes/Manifest1
-rw-r--r--dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch17
-rw-r--r--dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild25
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pytest-flakes/Manifest b/dev-python/pytest-flakes/Manifest
index 7e34bbf744c1..c0f281a3b50f 100644
--- a/dev-python/pytest-flakes/Manifest
+++ b/dev-python/pytest-flakes/Manifest
@@ -1 +1,2 @@
DIST pytest-flakes-4.0.2.tar.gz 7225 BLAKE2B 3a5ec59e3df90b6bf90daf5cf4abdf2946852a8e62a98ed08e5ba93c2e3f9e93699b2a4b571df45edac83e4c1791a5828b0bcca2a26a37b71f01d81bf3f0342f SHA512 bb1fc432e2494367849acedecba80495ede34c18dcf3ada09ef3dec8567d55f8dd6ba427bc3d9e47cfe3c0bb2aba80576612282d5a71858ccb45bce458f8656c
+DIST pytest-flakes-4.0.3.tar.gz 7312 BLAKE2B cf62d7e11a0521592325492c76e67cd51384b31d8a6191f10940230014c9a8797b3603e24664c022add5cec18ff7c3b558cd7507af47e8c90a9e90499f39e583 SHA512 ca63d68063cf48789d86dee3707b3ea7c5076fc1f636e17f408ad6f444303fb3a701af8d1e464d49af745e350272bffe8596853a52c01baa0bdb0b6b0c0bb303
diff --git a/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch b/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch
new file mode 100644
index 000000000000..35b4809c865b
--- /dev/null
+++ b/dev-python/pytest-flakes/files/pytest-flakes-4.0.3-fix-py3.10.patch
@@ -0,0 +1,17 @@
+From: Arthur Zamarin <arthurzam@gentoo.org>
+Date: Fri, 27 Aug 2021 08:23:16 +0300
+Subject: [PATCH] test_syntax_error: fix for python 3.10
+
+Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
+--- a/test_flakes.py
++++ b/test_flakes.py
+@@ -20,7 +20,8 @@ for x in []
+ pass
+ """)
+ result = testdir.runpytest("--flakes", "--ignore", testdir.tmpdir)
+- assert "1: invalid syntax" in result.stdout.str()
++ assert ("1: invalid syntax" in result.stdout.str() or
++ "1: expected ':'" in result.stdout.str())
+ assert 'passed' not in result.stdout.str()
+
+
diff --git a/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
new file mode 100644
index 000000000000..d3a52d73420f
--- /dev/null
+++ b/dev-python/pytest-flakes/pytest-flakes-4.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/pytest-flakes/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.10.patch"
+)
+
+distutils_enable_tests pytest