summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-02 04:52:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-02 04:52:35 +0200
commit9b16171a9ed8cf2624472b497710870bf2e6d262 (patch)
tree08d774e347be7fb35e169aa29fa20c7556bf4fdb /dev-python/pytest-skip-markers
parentdev-python/pywayland: Remove old (diff)
downloadgentoo-9b16171a9ed8cf2624472b497710870bf2e6d262.tar.gz
gentoo-9b16171a9ed8cf2624472b497710870bf2e6d262.tar.bz2
gentoo-9b16171a9ed8cf2624472b497710870bf2e6d262.zip
dev-python/pytest-skip-markers: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-skip-markers')
-rw-r--r--dev-python/pytest-skip-markers/Manifest1
-rw-r--r--dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/pytest-skip-markers/Manifest b/dev-python/pytest-skip-markers/Manifest
index 84efe0271147..37ed6f7dbc5b 100644
--- a/dev-python/pytest-skip-markers/Manifest
+++ b/dev-python/pytest-skip-markers/Manifest
@@ -1,2 +1 @@
-DIST pytest-skip-markers-1.4.0.gh.tar.gz 70932 BLAKE2B d1bd597de0004ca37d8582896166be8f70833b386adbb53e5f812b28ac15bca613fea5e85b21bfb3549892f45ea8bbff13e66bafb97fc5db93e2fc6226a73c85 SHA512 6cb88833fd328f8e7cc6a2d0c8a0c9106b07186b8a20164c8272d685e93c21b111d4e7885ac1739ce777a9279a59705229ea41c3c31c71ac71d1bc26c13318f2
DIST pytest-skip-markers-1.4.1.gh.tar.gz 71828 BLAKE2B 2abd097c529a6db51f36de6f5ac705da981e87196da4ccf99895b24277e9d4d717c80ebcf6b8d72959b7f76a10f23c2be11608c390845cca215472d2d4e99326 SHA512 c54cd2cafbe29648cfeccc2dc25b245e2e1a226ca6eb9e1c77e6aeb705e06c4b67854dd81673955fb77e16d1128c247d92d38d19dbedbdf01924a95c01721f3c
diff --git a/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild b/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild
deleted file mode 100644
index 81653ef30256..000000000000
--- a/dev-python/pytest-skip-markers/pytest-skip-markers-1.4.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Pytest plugin which implements a few useful skip markers"
-HOMEPAGE="
- https://pytest-skip-markers.readthedocs.io/en/latest/
- https://github.com/saltstack/pytest-skip-markers
-"
-SRC_URI="
- https://github.com/saltstack/pytest-skip-markers/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/pytest-7.1.0[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/distro[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- dev-python/pip[${PYTHON_USEDEP}]
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- dev-python/pytest-subtests[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=pytestskipmarkers.plugin,pyfakefs.pytest_plugin
- epytest
-}