summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-09 11:41:59 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-09 11:41:59 +0100
commit0a4e0fbe442d270e5af661bb117c0c6530a01e09 (patch)
tree9567db13dfa05242b9f85233021c716fa288fd4d /dev-python/pytest
parentdev-python/markdown: Remove stale pypy3.7 deps (diff)
downloadgentoo-0a4e0fbe442d270e5af661bb117c0c6530a01e09.tar.gz
gentoo-0a4e0fbe442d270e5af661bb117c0c6530a01e09.tar.bz2
gentoo-0a4e0fbe442d270e5af661bb117c0c6530a01e09.zip
dev-python/pytest: Remove stale pypy3.7 deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/pytest-5.4.3-r1.ebuild (renamed from dev-python/pytest/pytest-5.4.3.ebuild)7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/pytest/pytest-5.4.3.ebuild b/dev-python/pytest/pytest-5.4.3-r1.ebuild
index 360ea627d1f8..aac5743ce9fb 100644
--- a/dev-python/pytest/pytest-5.4.3.ebuild
+++ b/dev-python/pytest/pytest-5.4.3-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
+PYTHON_COMPAT=( python3_{8,9} pypy3 )
inherit distutils-r1
@@ -25,9 +25,6 @@ PY_VER="1.5.0"
# support, which only came in py3.6.
RDEPEND="
>=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_{6,7} pypy3)
>=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
dev-python/packaging[${PYTHON_USEDEP}]
>=dev-python/pluggy-0.12[${PYTHON_USEDEP}]