summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-11-12 09:26:55 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-11-12 09:27:58 +0200
commit463842a218003a3d94771b5463ca25ceb3060fb3 (patch)
tree603e752328e0ad49d772f8c665a4cd19695b08f2 /dev-python/python-efl
parentdev-python/python-efl: stabilize 1.25.0 on amd64 (diff)
downloadgentoo-463842a218003a3d94771b5463ca25ceb3060fb3.tar.gz
gentoo-463842a218003a3d94771b5463ca25ceb3060fb3.tar.bz2
gentoo-463842a218003a3d94771b5463ca25ceb3060fb3.zip
dev-python/python-efl: clean old 1.24.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/python-efl')
-rw-r--r--dev-python/python-efl/Manifest1
-rw-r--r--dev-python/python-efl/files/python-efl-1.24-clang.patch31
-rw-r--r--dev-python/python-efl/python-efl-1.24.0.ebuild75
3 files changed, 0 insertions, 107 deletions
diff --git a/dev-python/python-efl/Manifest b/dev-python/python-efl/Manifest
index b3efa8b5067a..85e4d62721f9 100644
--- a/dev-python/python-efl/Manifest
+++ b/dev-python/python-efl/Manifest
@@ -1,2 +1 @@
-DIST python-efl-1.24.0.tar.xz 9535212 BLAKE2B ab9535d60af75422f3c055e56f3c6297f595afbf682970afcb21f597486b307504fa83ab894c2029fb681dda8d886d1fc837726d1c4ae62df7185fbc0073724a SHA512 5b57de58b2351f00f744454e6aaa16f7bf9cf72b7f73d07a2d98cda4d152eb65810513b5c04b1eda127b6f5caf56e4b9bc9a7c1ef98593edde26a9ed3be953c9
DIST python-efl-1.25.0.tar.xz 9543920 BLAKE2B fc2b951ade2fc2b7c32dd78a84800bc9f225499ee9d8431034b378c86e423181d918aba2c4d056974f3aa2df9cfb9c7b3dcf1c366362387048cde182c0b3128a SHA512 23ed29add25cd2639e9eb144f22c5e2809b8634389f7ab5c4b7ebc19302fde4ebb0fe8c41d7b10923e658676c4dfbb8670fda16675682fd376258beecbc3d9c3
diff --git a/dev-python/python-efl/files/python-efl-1.24-clang.patch b/dev-python/python-efl/files/python-efl-1.24-clang.patch
deleted file mode 100644
index a6f18d866300..000000000000
--- a/dev-python/python-efl/files/python-efl-1.24-clang.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -Naur a/setup.py b/setup.py
---- a/setup.py 2020-04-23 08:20:55.742402600 +0300
-+++ b/setup.py 2020-09-22 08:29:43.065243208 +0300
-@@ -211,13 +211,21 @@
- py_modules = []
- packages = ["efl"]
- common_cflags = [
-- "-fno-var-tracking-assignments", # seems to lower the mem used during build
-- "-Wno-misleading-indentation", # not needed (we don't indent the C code)
-- "-Wno-deprecated-declarations", # we bind deprecated functions
-- "-Wno-unused-variable", # eo_instance_from_object() is unused
-- "-Wno-format-security", # some cc don't like the way cython use EINA_LOG macros
-- # "-Werror", "-Wfatal-errors" # use this to stop build on first warnings
-+ "-fno-var-tracking-assignments", # seems to lower the mem used during build
-+ "-Wno-misleading-indentation", # not needed (we don't indent the C code)
-+ "-Wno-deprecated-declarations", # we bind deprecated functions
-+ "-Wno-unused-variable", # eo_instance_from_object() is unused
-+ "-Wno-format-security", # some cc don't like the way cython use EINA_LOG macros
-+ # "-Werror", "-Wfatal-errors" # use this to stop build on first warnings
- ]
-+# remove clang unknown flags
-+if os.getenv("CC") == "clang":
-+ common_cflags.remove('-fno-var-tracking-assignments')
-+if os.getenv("CC") == "x86_64-pc-linux-gnu-clang":
-+ common_cflags.remove('-fno-var-tracking-assignments')
-+if os.getenv("CC") == "i686-pc-linux-gnu-clang":
-+ common_cflags.remove('-fno-var-tracking-assignments')
-+
-
- if set(("build", "build_ext", "install", "bdist", "sdist")) & set(sys.argv):
- sys.stdout.write("Python-EFL: %s\n" % RELEASE)
diff --git a/dev-python/python-efl/python-efl-1.24.0.ebuild b/dev-python/python-efl/python-efl-1.24.0.ebuild
deleted file mode 100644
index d1a7a54ab74b..000000000000
--- a/dev-python/python-efl/python-efl-1.24.0.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..8} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Python bindings for Enlightenment Foundation Libraries"
-HOMEPAGE="https://phab.enlightenment.org/w/projects/python_bindings_for_efl/"
-SRC_URI="https://download.enlightenment.org/rel/bindings/python/${P}.tar.xz"
-
-LICENSE="|| ( GPL-3 LGPL-3 )"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-
-RESTRICT="!test? ( test )"
-
-RDEPEND="=dev-libs/efl-1.24*
- dev-python/dbus-python[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]"
-BDEPEND="virtual/pkgconfig
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- media-gfx/graphviz
- )"
-
-PATCHES=( "${FILESDIR}/python-efl-1.24-clang.patch" )
-
-src_prepare() {
- default
-
- # Tries to download a file under /tmp
- rm tests/ecore/test_09_file_download.py || die
-
- # Tries to use that file which failed to download
- rm tests/ecore/test_10_file_monitor.py || die
-
- # Needs an active internet connection
- rm tests/ecore/test_11_con.py || die
-
- # Test fails because of deleted files above
- sed -i 's/>= 13/>= 10/g' tests/ecore/test_08_exe.py || die
-
- # Make tests verbose
- sed -i 's:verbosity=1:verbosity=3:' tests/00_run_all_tests.py || die
-
- # Disable any optimization on x86, #704260
- if use x86; then
- filter-flags -O?
- append-cflags -O0
- fi
-}
-
-python_compile_all() {
- if use doc ; then
- esetup.py build_doc --build-dir "${S}"/build/doc/
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- cd tests/ || die
- ${EPYTHON} 00_run_all_tests.py --verbose || die "Tests failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( ./build/doc/html/. )
- distutils-r1_python_install_all
-}