summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 22:13:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 22:24:47 +0100
commit607ec0ecc7bcaeda13ad50a37cb22c32d3abf60b (patch)
treef340e935af2c95db8c8367ea17b5be121c6edc44 /dev-python/pyudev
parentnet-libs/neon: 0.31.0 version bump (diff)
downloadgentoo-607ec0ecc7bcaeda13ad50a37cb22c32d3abf60b.tar.gz
gentoo-607ec0ecc7bcaeda13ad50a37cb22c32d3abf60b.tar.bz2
gentoo-607ec0ecc7bcaeda13ad50a37cb22c32d3abf60b.zip
dev-python/pyudev: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyudev')
-rw-r--r--dev-python/pyudev/Manifest1
-rw-r--r--dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch78
-rw-r--r--dev-python/pyudev/pyudev-0.21.0.ebuild55
3 files changed, 0 insertions, 134 deletions
diff --git a/dev-python/pyudev/Manifest b/dev-python/pyudev/Manifest
index e888f4c61e96..ed167c9a1c1b 100644
--- a/dev-python/pyudev/Manifest
+++ b/dev-python/pyudev/Manifest
@@ -1,2 +1 @@
-DIST pyudev-0.21.0.tar.gz 89469 BLAKE2B 3bf9ac46442c5948d131932c7b62a59ef979755f2d55bcd0165fc1b69b865268051fdeab7605c8a1cb0694ce0f4b88f31a1e6a1893900a7300ddf6439734712e SHA512 ba5b6156768b65b9655d809b14378b01173643781b9c4017271e880cdfed442c44ac49eb26c970e4275b820e01678e3001870591fccf88dc713ec941e2b85d11
DIST pyudev-0.22.0.tar.gz 85077 BLAKE2B 66c78aa4d3bea5ceae3660a93e5bd1733629bb5228d67d8e647abb8c237a2786c1061b07e034be5467f5bcab58d95ba30f91d74bdc54cd8253dff69be3ad4a80 SHA512 a09ed479a54a1772a6af68cb975fef792068c2de3655e20223905bc3f574fd32bd3dbe6b97062eee3ab5f08a8b041ad3ea86dfb68c839ea44e29d65ec1686670
diff --git a/dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch b/dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch
deleted file mode 100644
index 268d2bdf1b4c..000000000000
--- a/dev-python/pyudev/files/pyudev-0.19.0-skip-non-deterministic-test.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/tests/_device_tests/_attributes_tests.py b/tests/_device_tests/_attributes_tests.py
-index 54d8ae6..84e26c3 100644
---- a/tests/_device_tests/_attributes_tests.py
-+++ b/tests/_device_tests/_attributes_tests.py
-@@ -88,6 +88,7 @@ def test_non_iterable(self, a_device):
- with pytest.raises(TypeError):
- a_device.attributes['key']
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asstring(self, a_context, device_datum):
-@@ -99,6 +100,7 @@ def test_asstring(self, a_context, device_datum):
- assert is_unicode_string(device.attributes.asstring(key))
- assert device.attributes.asstring(key) == value
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asint(self, a_context, device_datum):
-@@ -115,6 +117,7 @@ def test_asint(self, a_context, device_datum):
- else:
- assert device.attributes.asint(key) == value
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asbool(self, a_context, device_datum):
-diff --git a/tests/_device_tests/_device_tests.py b/tests/_device_tests/_device_tests.py
-index 92a767d..175c611 100644
---- a/tests/_device_tests/_device_tests.py
-+++ b/tests/_device_tests/_device_tests.py
-@@ -378,6 +378,7 @@ def test_getitem_nonexisting(self, a_device):
- a_device['a non-existing property']
- assert str(excinfo.value) == repr('a non-existing property')
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asint(self, a_context, device_datum):
-@@ -391,6 +392,7 @@ def test_asint(self, a_context, device_datum):
- else:
- assert device.asint(property) == value
-
-+ @pytest.mark.skipif(True, reason='Non-deterministic')
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_DEVICE_DATA))
- @settings(max_examples=5)
- def test_asbool(self, a_context, device_datum):
-diff --git a/tests/_device_tests/_devices_tests.py b/tests/_device_tests/_devices_tests.py
-index 8eb8069..b80e550 100644
---- a/tests/_device_tests/_devices_tests.py
-+++ b/tests/_device_tests/_devices_tests.py
-@@ -189,8 +189,8 @@ def test_from_device_file(self, a_context, device_datum):
-
- _device_data = [d for d in _DEVICE_DATA if list(d.device_links)]
- @pytest.mark.skipif(
-- len(_device_data) == 0,
-- reason='no device with a device node'
-+ True,
-+ reason='non deterministic'
- )
- @given(_CONTEXT_STRATEGY, strategies.sampled_from(_device_data))
- @settings(max_examples=5, min_satisfying_examples=1)
-diff --git a/tests/test_discover.py b/tests/test_discover.py
-index dd336d5..c410a64 100644
---- a/tests/test_discover.py
-+++ b/tests/test_discover.py
-@@ -155,8 +155,8 @@ def test_name(self, a_device):
-
- _devices = [d for d in _DEVICES if list(d.device_links)]
- @pytest.mark.skipif(
-- len(_devices) == 0,
-- reason="no device with device links"
-+ True,
-+ reason='Non-deterministic'
- )
- @given(strategies.sampled_from(_devices))
- @settings(max_examples=NUM_TESTS, min_satisfying_examples=1)
diff --git a/dev-python/pyudev/pyudev-0.21.0.ebuild b/dev-python/pyudev/pyudev-0.21.0.ebuild
deleted file mode 100644
index 684711ee05ca..000000000000
--- a/dev-python/pyudev/pyudev-0.21.0.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{3_6,3_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python binding to libudev"
-HOMEPAGE="https://pyudev.readthedocs.io/en/latest/ https://github.com/pyudev/pyudev"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~mips x86"
-IUSE="qt5 test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- virtual/udev
- qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/docutils[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
- )"
-
-DOCS=( CHANGES.rst README.rst )
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.19.0-skip-non-deterministic-test.patch"
-)
-
-python_prepare_all() {
- if use test; then
- ewarn "If your PORTAGE_TMPDIR is longer in length then '/var/tmp/',"
- ewarn "change it to /var/tmp to ensure tests will pass."
- fi
-
- # tests are known to pass then fail on alternate runs
- # tests: fix run_path
- sed -i -e "s|== \('/run/udev'\)|in (\1,'/dev/.udev')|g" \
- tests/test_core.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}