summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-10-03 16:55:39 +0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-10-06 09:43:13 +0200
commit8375a791a485e2169fed9c164a4e2d83b0bcb01a (patch)
tree7a5c7eff7c41c6013c54fbd2e50d769095f612c7 /dev-python/shiboken6
parentdev-lang/spidermonkey: add 115.3.1 (diff)
downloadgentoo-8375a791a485e2169fed9c164a4e2d83b0bcb01a.tar.gz
gentoo-8375a791a485e2169fed9c164a4e2d83b0bcb01a.tar.bz2
gentoo-8375a791a485e2169fed9c164a4e2d83b0bcb01a.zip
dev-python/shiboken6: bump LLVM_MAX_SLOT to 16
Clang-16 has been supported since 6.5.1 * https://github.com/pyside/pyside-setup/blob/dev/doc/changelogs/changes-6.5.1 * https://github.com/pyside/pyside-setup/commit/44ef1859214c66861a251d4a0faf5c38dc050850 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/33167 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/shiboken6')
-rw-r--r--dev-python/shiboken6/shiboken6-6.5.2-r2.ebuild (renamed from dev-python/shiboken6/shiboken6-6.5.2-r1.ebuild)15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-python/shiboken6/shiboken6-6.5.2-r1.ebuild b/dev-python/shiboken6/shiboken6-6.5.2-r2.ebuild
index 365771516fcd..359316a52fac 100644
--- a/dev-python/shiboken6/shiboken6-6.5.2-r1.ebuild
+++ b/dev-python/shiboken6/shiboken6-6.5.2-r2.ebuild
@@ -40,11 +40,11 @@ RESTRICT="test"
QT_PV="$(ver_cut 1-3)*:6"
# Since Clang is required at both build- and runtime, BDEPEND is omitted here.
-LLVM_MAX_SLOT=15
+LLVM_MAX_SLOT=16
RDEPEND="${PYTHON_DEPS}
=dev-qt/qtbase-${QT_PV}
- <sys-devel/clang-16:=
- <sys-devel/clang-runtime-16:=
+ <sys-devel/clang-17:=
+ <sys-devel/clang-runtime-17:=
docstrings? (
>=dev-libs/libxml2-2.6.32
>=dev-libs/libxslt-1.1.19
@@ -82,6 +82,13 @@ src_prepare() {
ApiExtractor/clangparser/compilersupport.cpp || die
fi
+ local clangver="$(CPP=clang clang-major-version)"
+
+ # Clang 15 and older used the full version as a directory name.
+ if [[ ${clangver} -lt 16 ]]; then
+ clangver="$(CPP=clang clang-fullversion)"
+ fi
+
# Shiboken6 assumes the "/usr/lib/clang/${CLANG_NEWEST_VERSION}/include/"
# subdirectory provides Clang builtin includes (e.g., "stddef.h") for the
# currently installed version of Clang, where ${CLANG_NEWEST_VERSION} is
@@ -97,7 +104,7 @@ src_prepare() {
# PySide6 does *NOT* care whether the end user has done so or not, as
# PySide6 unconditionally requires Clang in either case. See also:
# https://bugs.gentoo.org/619490
- sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
+ sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'"${clangver}"'/include"))~' \
ApiExtractor/clangparser/compilersupport.cpp || die
cmake_src_prepare