summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-21 09:57:35 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-21 10:15:51 +0100
commitf1ebdedf3ea65ea3835664f9542a2194f6c3cb2d (patch)
tree1001dd447354e5d43db795600ea63c140510b104 /dev-python/tldextract
parentdev-python/jaraco-itertools: Bump to 6.2.1 (diff)
downloadgentoo-f1ebdedf3ea65ea3835664f9542a2194f6c3cb2d.tar.gz
gentoo-f1ebdedf3ea65ea3835664f9542a2194f6c3cb2d.tar.bz2
gentoo-f1ebdedf3ea65ea3835664f9542a2194f6c3cb2d.zip
dev-python/tldextract: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tldextract')
-rw-r--r--dev-python/tldextract/Manifest1
-rw-r--r--dev-python/tldextract/tldextract-3.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/tldextract/Manifest b/dev-python/tldextract/Manifest
index 3cae18775728..cfd8205d34b6 100644
--- a/dev-python/tldextract/Manifest
+++ b/dev-python/tldextract/Manifest
@@ -1 +1,2 @@
DIST tldextract-3.1.2.tar.gz 103248 BLAKE2B 5612016be7e8cd9b75dc5225f87ebc28635d66a7cacee54af2bd8db6ed6bb26ffe6ee5b4ab9b24473f19f0ad8d9d536e24236106288cd82cf635abef81f9babd SHA512 2c2340a9142d49aa7c0db71b5a7fb1a63e19354a5da8edd7de923e55c8ec03d8a8551f4710c66d6d1aece1d0d78701229ef5ed2ed49bcce44972b7b96747bd77
+DIST tldextract-3.2.0.tar.gz 103653 BLAKE2B 74b85da2e5a8c953075636f908bd32ba825c53fbea145a691cb681596376318b63729e2c6b7291f1ef21a55fa927d48e31cf0db241bb94be47f706fb68239515 SHA512 4e0731792793eb0a6d0da8387d15e8b9de17f20108361230703fd9f66f2aaad6260073b611e27135e571b1899844b271f3dae4e77122186cc78fbb05f3b3f237
diff --git a/dev-python/tldextract/tldextract-3.2.0.ebuild b/dev-python/tldextract/tldextract-3.2.0.ebuild
new file mode 100644
index 000000000000..ef7d2500fe3e
--- /dev/null
+++ b/dev-python/tldextract/tldextract-3.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Accurately separate the TLD from the registered domain and subdomains of a URL"
+HOMEPAGE="https://pypi.org/project/tldextract/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest