summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/turbocheetah
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/turbocheetah')
-rw-r--r--dev-python/turbocheetah/Manifest1
-rw-r--r--dev-python/turbocheetah/metadata.xml8
-rw-r--r--dev-python/turbocheetah/turbocheetah-1.0-r1.ebuild33
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/turbocheetah/Manifest b/dev-python/turbocheetah/Manifest
new file mode 100644
index 000000000000..6951fb5fecb0
--- /dev/null
+++ b/dev-python/turbocheetah/Manifest
@@ -0,0 +1 @@
+DIST TurboCheetah-1.0.tar.gz 4335 SHA256 9e4c7ecb0d061bfb58281363ee1b09337083f013a8b4d0355326a5d8668f450c SHA512 7f231ee1e9f09c2c73a6a3c3be04643e6a13f2e488329d086cba759a75bfaf6c3f5b1670d21dec54bf3df8f2a449faa365c600ae47705295e13727ea4fccbb92 WHIRLPOOL 3a59280b1e805631043e06766a0df98e47d76d0b6c062c336a4daf205d1b8606f975d37c80e9d6374ca0365b910a67d7ad44e3b4bd8bc6b87e147c2c00033336
diff --git a/dev-python/turbocheetah/metadata.xml b/dev-python/turbocheetah/metadata.xml
new file mode 100644
index 000000000000..d0d144ae606d
--- /dev/null
+++ b/dev-python/turbocheetah/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">TurboCheetah</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/turbocheetah/turbocheetah-1.0-r1.ebuild b/dev-python/turbocheetah/turbocheetah-1.0-r1.ebuild
new file mode 100644
index 000000000000..29dc58fc46a4
--- /dev/null
+++ b/dev-python/turbocheetah/turbocheetah-1.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+#DISTUTILS_SRC_TEST="nosetests"
+
+MY_PN="TurboCheetah"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="TurboGears plugin to support use of Cheetah templates"
+HOMEPAGE="http://docs.turbogears.org/TurboCheetah http://pypi.python.org/pypi/TurboCheetah"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/cheetah-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests || die "test failed"
+}