summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-03 03:02:53 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-03 03:51:58 +0200
commitd60e4894ded5362ed48bc59f5650293c0b2326f2 (patch)
tree55f374b94a5bc81201033df1dc3d78e6c37932bc /dev-python/uvicorn
parentmail-filter/spamassassin: Fix sa_txrep test when no dbm (diff)
downloadgentoo-d60e4894ded5362ed48bc59f5650293c0b2326f2.tar.gz
gentoo-d60e4894ded5362ed48bc59f5650293c0b2326f2.tar.bz2
gentoo-d60e4894ded5362ed48bc59f5650293c0b2326f2.zip
dev-python/uvicorn: Bump to 0.30.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest1
-rw-r--r--dev-python/uvicorn/uvicorn-0.30.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 57a48cf100d1..ac307b420dd0 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,2 +1,3 @@
DIST uvicorn-0.29.0.gh.tar.gz 719202 BLAKE2B 15a1e9d001e00805d9efe89c1b46416f6556d944ec5a32fb31c8368d4c0e1e32155169e9b5754c7d56a3ee86a1b7edddcf0d9a641abf74fdb89c1332ebd289af SHA512 bb37940acc2eba2a649d07ba44890400332e5ad873ac03c6740c1bc730068ede39c2e6d9aefb0f100ec261d7ed2eef1596c99a060fd8000cff874b25bdbbbdfa
DIST uvicorn-0.30.0.gh.tar.gz 722322 BLAKE2B 5868f27cf8589b00737c77904dd60a4996641610bd9216744c89fbf39956d4f2764249b45f7736c11141f214544aeaaf196d22421fb52596a9e3517931d500c2 SHA512 1e090fe7b1a5eb00fa11359694e5bc0a577d206e97e65c6dba0b401c2c2d11d621ed69b5f0e883e1757a660a823d0f3ab4fe9a041bb3f738086337ac8dad108b
+DIST uvicorn-0.30.1.gh.tar.gz 722580 BLAKE2B 33cb5683bf8d3f3bbc2a17a354356adee2be66259cd79413c9f1ef698485c46060a609a8f0a28cef05de71631569ac61c12aad6913a3243f45eb7e1691a481ea SHA512 ce705c1e99ca0feff3f82e067c0df9e21dea6ff3789541757edbc686718bcb0c80be392fd75f7c0962c5d7251e7e3e441e97633057dcb43e565c48a4d6b3d392
diff --git a/dev-python/uvicorn/uvicorn-0.30.1.ebuild b/dev-python/uvicorn/uvicorn-0.30.1.ebuild
new file mode 100644
index 000000000000..9511a7d54223
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.30.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+# as of 0.28.0, no tests in sdist
+SRC_URI="
+ https://github.com/encode/uvicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+BDEPEND="
+ test? (
+ dev-python/a2wsgi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/watchfiles[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ )
+ case ${EPYTHON} in
+ pypy3)
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ ;;
+ esac
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}