summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-30 23:07:31 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-30 23:14:22 +0200
commit60fc34833dbfa8c3392501d5c29ba8b2781b7013 (patch)
tree8517ccd1a6d80a86bd7ccd915d22f35a8af60c93 /dev-python/ws4py
parentprofiles/base: Mask www-apps/nikola[websocket] (diff)
downloadgentoo-60fc34833dbfa8c3392501d5c29ba8b2781b7013.tar.gz
gentoo-60fc34833dbfa8c3392501d5c29ba8b2781b7013.tar.bz2
gentoo-60fc34833dbfa8c3392501d5c29ba8b2781b7013.zip
dev-python/ws4py: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/Manifest1
-rw-r--r--dev-python/ws4py/files/ws4py-0.3.4-tests.patch67
-rw-r--r--dev-python/ws4py/ws4py-0.3.4-r1.ebuild55
3 files changed, 0 insertions, 123 deletions
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
index 73f87f82749e..7f62255c2b2b 100644
--- a/dev-python/ws4py/Manifest
+++ b/dev-python/ws4py/Manifest
@@ -1,2 +1 @@
-DIST ws4py-0.3.4.tar.gz 65467 BLAKE2B c51e338f3c65e100b55e83cd7b09fb8e4eafec3adc118a2744ea4aabc54c91efacda94cb3018550049d617b6759198cfbdb4497a024c597de942abe9e5517ab6 SHA512 32cd2eb9df7367e2bf42e354766a0ca407715a863be6b51b7701ec6e0537a2ecf7c2a59423f56ae093855b075c30a4065c7f7efe3b0227915639223b9ba7a55f
DIST ws4py-0.5.1.tar.gz 116673 BLAKE2B 31db304800f0d3da61dc4c1a3381a8fcfcfa8f16b36d916311cc32f1d294c9f7b3627dac673edf824f529f485f825ca418ab1e1a8a2fda5583c6a6a1bd9b752c SHA512 4c90d66d37fb5bdc8f7fc9fd184b20a7dc2dae811ecf3a041477e3c26a2577008be7041799daca5b8c0de65cb2454022a6c135cf02534ca98b6946abbfce0e11
diff --git a/dev-python/ws4py/files/ws4py-0.3.4-tests.patch b/dev-python/ws4py/files/ws4py-0.3.4-tests.patch
deleted file mode 100644
index dde60f2ed04d..000000000000
--- a/dev-python/ws4py/files/ws4py-0.3.4-tests.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 185c88cb6779b3b15a5c14047bb62b8fcb8d2e57 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Sat, 10 Mar 2018 00:33:37 +0100
-Subject: [PATCH] Fix AttributeErrors from mistaken Mock.assert_call_once_with
-
-This commit is a backport/subset of:
-https://github.com/Lawouach/WebSocket-for-Python/commit/b5d47f7b3497f1b713a20fe6306b7d9afdd8c408
----
- test/test_manager.py | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/test/test_manager.py b/test/test_manager.py
-index 8c229b0..aacc162 100644
---- a/test/test_manager.py
-+++ b/test/test_manager.py
-@@ -16,10 +16,10 @@ class WSManagerTest(unittest.TestCase):
- ws.sock.fileno.return_value = 1
-
- m.add(ws)
-- m.poller.register.assert_call_once_with(ws)
-+ m.poller.register.assert_called_once_with(1)
-
- m.remove(ws)
-- m.poller.unregister.assert_call_once_with(ws)
-+ m.poller.unregister.assert_called_once_with(1)
-
- @patch('ws4py.manager.SelectPoller')
- def test_cannot_add_websocket_more_than_once(self, MockSelectPoller):
-@@ -49,7 +49,7 @@ class WSManagerTest(unittest.TestCase):
- self.assertEqual(len(m), 1)
- m.remove(ws)
- self.assertEqual(len(m), 0)
-- m.poller.unregister.assert_call_once_with(ws)
-+ m.poller.unregister.assert_called_once_with(1)
- m.poller.reset_mock()
-
- m.remove(ws)
-@@ -98,7 +98,7 @@ class WSManagerTest(unittest.TestCase):
- m.add(ws)
- m.start()
-
-- ws.terminate.assert_call_once_with()
-+ ws.terminate.assert_called_once_with()
-
- m.stop()
-
-@@ -109,7 +109,7 @@ class WSManagerTest(unittest.TestCase):
- ws = MagicMock()
- m.add(ws)
- m.close_all()
-- ws.terminate.assert_call_once_with(1001, 'Server is shutting down')
-+ ws.close.assert_called_once_with(code=1001, reason='Server is shutting down')
-
- @patch('ws4py.manager.SelectPoller')
- def test_broadcast(self, MockSelectPoller):
-@@ -120,7 +120,7 @@ class WSManagerTest(unittest.TestCase):
- m.add(ws)
-
- m.broadcast(b'hello there')
-- ws.send.assert_call_once_with(b'hello there')
-+ ws.send.assert_called_once_with(b'hello there', False)
-
- @patch('ws4py.manager.SelectPoller')
- def test_broadcast_failure_must_not_break_caller(self, MockSelectPoller):
---
-2.16.2
-
diff --git a/dev-python/ws4py/ws4py-0.3.4-r1.ebuild b/dev-python/ws4py/ws4py-0.3.4-r1.ebuild
deleted file mode 100644
index d6697eff1d24..000000000000
--- a/dev-python/ws4py/ws4py-0.3.4-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# We could depend on dev-python/cherrypy when USE=server, but
-# that is an optional component ...
-# Same for www-servers/tornado and USE=client ... so why not???
-# pypy is viable but better with a cutdown set of deps
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="threads?"
-
-inherit distutils-r1
-if [[ ${PV} == *9999* ]] ; then
- EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-r3
-else
- inherit vcs-snapshot
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/v${PV} -> ${P}.tar.gz"
- KEYWORDS="amd64 arm x86"
-fi
-
-DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
-HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="+client +server test +threads"
-RESTRICT="!test? ( test )"
-# doc build requires sphinxcontrib ext packages absent from portage
-
-RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
- server? ( <dev-python/cherrypy-9[${PYTHON_USEDEP}] )"
-DEPEND="test? (
- <dev-python/cherrypy-9[${PYTHON_USEDEP}]
- dev-python/unittest2[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.3.4-tests.patch
-)
-
-python_test() {
- # testsuite displays an issue with mock under py3 but is non fatal
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}
-
-python_install() {
- distutils-r1_python_install
- use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
- use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
-}