summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-01-23 19:52:15 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-01-23 20:18:40 +0200
commit125cf41c8910407fac00b1e6491e7e862f67b7bb (patch)
treee333f1fc2093f404fbffa46be1b45a769279ac20 /dev-python
parentdev-python/tavern: add 2.9.0 (diff)
downloadgentoo-125cf41c8910407fac00b1e6491e7e862f67b7bb.tar.gz
gentoo-125cf41c8910407fac00b1e6491e7e862f67b7bb.tar.bz2
gentoo-125cf41c8910407fac00b1e6491e7e862f67b7bb.zip
dev-python/hypothesis: add 6.96.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.96.4.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 6a219c8cfcce..25bb4a6d04a0 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -9,3 +9,4 @@ DIST hypothesis-6.94.0.gh.tar.gz 9418907 BLAKE2B 856ab9b074e308cc61c8a5d030d7d7d
DIST hypothesis-6.96.0.gh.tar.gz 9419802 BLAKE2B 347801a68db086f2f22c8cd49d1cb8f2e9dff5373fba4c2f5563734a4f198b7972b69ad3856604d5c9bb67c68e82fe70a8b54f27f16c2bf08672fc2eed1c084e SHA512 2c29d3d443f34381d8dc04fec1e5aeccf9a55790f9bc30aaca27e65521023605501d06251090a0b1ff321b9e88f08120c52be0c59878e7ea9e2d8e8ad44ded80
DIST hypothesis-6.96.1.gh.tar.gz 9420126 BLAKE2B 546b9c77a144b58490fb5b6ba51fdff6e4f953bd942ce7a94a937e442e44526703479b5786787597e1af6028eb252e8d242f268c50591d83d2ffc438daeb006f SHA512 6c34819c8929d038c42e6539483a1d1c3f4c5dea7a5bed4db96194255b4f41ec3751a91f0eae242c27c9cf2135eb4428f0e759c596b6841fb95d7f971c5a5fe8
DIST hypothesis-6.96.3.gh.tar.gz 9421880 BLAKE2B 0d73e363550ca45c316ddf05bc0615aaf9846482b0aaaf64daa0879ac716314b222afdd37aaf29bc00c32f3cfd984609292151e458c5b1165144b1d870cc698e SHA512 8d847e9db1ce83ebed7307be8df91dc517b37cf2588ddf005a158f8b3dca2cb3ee95ed5268d1d74d25a374959f7553d1fa8ab2bc83f314113042c090970a5307
+DIST hypothesis-6.96.4.gh.tar.gz 9422075 BLAKE2B 0ab12a01c8d714490f3785ac01779c69d0dc5f31bb3c85be3c1ff9831c1b2392f19ec45adfd40f334f20d48b3ad1300d38ed2e49ca318f17cae36de44895bc3d SHA512 8cbfbf36c7e1e56c31b58aadd9e592672430492eb7c7fb570d4e1277df3e0dd83f76ef39e27e0c644e38c3bc35c993b79d1e6687be73c0780fa36840b4a2baec
diff --git a/dev-python/hypothesis/hypothesis-6.96.4.ebuild b/dev-python/hypothesis/hypothesis-6.96.4.ebuild
new file mode 100644
index 000000000000..f7f366381e4f
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.96.4.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}