summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-12 05:03:59 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-12 05:15:36 +0100
commit22148aaca727560b3cc76a36850cb6678c5cea2c (patch)
treebc7c6ac4ddacf53d77620cfc5f67e2ac0f6b9f77 /dev-python
parentdev-python/tekore: Remove old (diff)
downloadgentoo-22148aaca727560b3cc76a36850cb6678c5cea2c.tar.gz
gentoo-22148aaca727560b3cc76a36850cb6678c5cea2c.tar.bz2
gentoo-22148aaca727560b3cc76a36850cb6678c5cea2c.zip
dev-python/opentelemetry-sdk: Bump to 1.29.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/opentelemetry-sdk/Manifest1
-rw-r--r--dev-python/opentelemetry-sdk/opentelemetry-sdk-1.29.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/opentelemetry-sdk/Manifest b/dev-python/opentelemetry-sdk/Manifest
index 145836412bcb..a6e357ee17a4 100644
--- a/dev-python/opentelemetry-sdk/Manifest
+++ b/dev-python/opentelemetry-sdk/Manifest
@@ -1 +1,2 @@
DIST opentelemetry-python-1.28.2.gh.tar.gz 639603 BLAKE2B 6c185c91cd3f31c58f8f1f73edfbe1b5b242bf8ac855e573a40b6f3ea73dc558b40d89785a9e24d61c2b4950a008c5bc51f319013f955877d14028f9b88101b7 SHA512 49f97ffb1bec390eaa9181bfc16eb0c5b1f7b50602a5edbcf4851fb7077685eff3f261738143be59184e6a01c283fac4f766602eebd9b6daea74005cf3e0c4d9
+DIST opentelemetry-python-1.29.0.gh.tar.gz 1178849 BLAKE2B f26914c14025e77486df0c587318f96c4b27bd2caeacc877091300fc054f4670a642ca6fcafa909b986a97168ab004d4a969a05571ee38ab7797b3b38f4cc91f SHA512 92c90e6a684d8cfab3bba4d72612ccf53ae54cdd9784e3434b25adc3730fe114f21fd7aa21da80edf6e0e7c80b39c64ee31fb16f68b04809289bbf5d49d4ca2e
diff --git a/dev-python/opentelemetry-sdk/opentelemetry-sdk-1.29.0.ebuild b/dev-python/opentelemetry-sdk/opentelemetry-sdk-1.29.0.ebuild
new file mode 100644
index 000000000000..11e9ed4f6c7c
--- /dev/null
+++ b/dev-python/opentelemetry-sdk/opentelemetry-sdk-1.29.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+MY_P="opentelemetry-python-${PV}"
+DESCRIPTION="OpenTelemetry Python SDK"
+HOMEPAGE="
+ https://opentelemetry.io/
+ https://pypi.org/project/opentelemetry-sdk/
+ https://github.com/open-telemetry/opentelemetry-python/
+"
+SRC_URI="
+ https://github.com/open-telemetry/opentelemetry-python/archive/refs/tags/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ ~dev-python/opentelemetry-api-${PV}[${PYTHON_USEDEP}]
+ ~dev-python/opentelemetry-semantic-conventions-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-3.7.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+# Tests cannot handle xdist with high makeopts
+# https://bugs.gentoo.org/928132
+distutils_enable_tests pytest
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ for dep in tests/opentelemetry-test-utils; do
+ pushd "${WORKDIR}/${MY_P}/${dep}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ local EPYTEST_DESELECT=(
+ # TODO
+ "${PN}"/tests/resources/test_resources.py::TestOTELResourceDetector::test_process_detector
+ "${PN}"/tests/metrics/integration_test/test_console_exporter.py::TestConsoleExporter::test_console_exporter_with_exemplars
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests
+}