summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-11 08:39:45 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-11 09:06:12 +0200
commit2326d4adb2988dcd72ecbe6e777118c8377f1e42 (patch)
treec2dc2789ed151b2462a5a194eb5e52425dced5c2 /dev-python
parentdev-python/PyPDF2: Bump to 2.5.0 (diff)
downloadgentoo-2326d4adb2988dcd72ecbe6e777118c8377f1e42.tar.gz
gentoo-2326d4adb2988dcd72ecbe6e777118c8377f1e42.tar.bz2
gentoo-2326d4adb2988dcd72ecbe6e777118c8377f1e42.zip
dev-python/huawei-lte-api: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/huawei-lte-api/Manifest1
-rw-r--r--dev-python/huawei-lte-api/huawei-lte-api-1.6.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/huawei-lte-api/Manifest b/dev-python/huawei-lte-api/Manifest
index 881e6024214b..58acc4b3d6e8 100644
--- a/dev-python/huawei-lte-api/Manifest
+++ b/dev-python/huawei-lte-api/Manifest
@@ -1 +1,2 @@
+DIST huawei-lte-api-1.6.1.gh.tar.gz 32963 BLAKE2B f159e1dc4cb759c09a88bb763c6ba5f43043eacf025e7ada871c816e0e72a238f9e7536dbc043f8596bef390ecfc2ee137c1a4c079ca33db6c3a3198147c9f98 SHA512 2a6a330c419af0d2b8eeff9d8b93a11cdf8050db04e609cb1d86a33ab770d7102c8e40652482c2500ce4bf4152b66b98ee1fc77be104db8ab9a9bbeec871ce20
DIST huawei-lte-api-1.6.tar.gz 32617 BLAKE2B 194d2d983e7bd5bd456d3557b16795cda350ea157545c1ce37aa6d4dd0bace8a8a0c724b9d0ae4315e6f95585598b147a03acb77d84837bf879fa9b83737cafc SHA512 62f70853bba0fbd863e07e2d91309fc15c41508857486d01a02ec30ed513567d0880551744eed5a61517cc33a2f56583df892d22cca45124e95e24605ab23678
diff --git a/dev-python/huawei-lte-api/huawei-lte-api-1.6.1.ebuild b/dev-python/huawei-lte-api/huawei-lte-api-1.6.1.ebuild
new file mode 100644
index 000000000000..5b62e249fda3
--- /dev/null
+++ b/dev-python/huawei-lte-api/huawei-lte-api-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="API For huawei LAN/WAN LTE Modems"
+HOMEPAGE="
+ https://github.com/Salamek/huawei-lte-api/
+ https://pypi.org/project/huawei-lte-api/
+"
+SRC_URI="
+ https://github.com/Salamek/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # make cryptodome-friendly
+ sed -i -e 's:pycryptodomex:pycryptodome:' setup.py || die
+ find -name '*.py' -exec \
+ sed -i -e 's:Cryptodome:Crypto:g' {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+distutils_enable_tests pytest