summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-11 09:00:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-11 09:09:23 +0200
commit4045520581d7acb856044e433eb6f049f2b94ff0 (patch)
tree10f6c0f2bd4d3a2db572220025eb0b2146612c7f /dev-python
parentdev-libs/nspr: fix paths in musl patch file (diff)
downloadgentoo-4045520581d7acb856044e433eb6f049f2b94ff0.tar.gz
gentoo-4045520581d7acb856044e433eb6f049f2b94ff0.tar.bz2
gentoo-4045520581d7acb856044e433eb6f049f2b94ff0.zip
dev-python/pyglet: Bump to 2.0.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyglet/Manifest1
-rw-r--r--dev-python/pyglet/pyglet-2.0.7.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyglet/Manifest b/dev-python/pyglet/Manifest
index b706928194a3..ea4c69ffbb7d 100644
--- a/dev-python/pyglet/Manifest
+++ b/dev-python/pyglet/Manifest
@@ -1,2 +1,3 @@
DIST pyglet-2.0.5.gh.tar.gz 6174681 BLAKE2B 6f4f80cee2984148a7579ad02ff86e6cc1c151688ace0153cf3a518eba3004518f900b0297877a86278f4159c342f190d22702bf1ebcaa254c4bef19e1ac0844 SHA512 54bd6630a61606a02103a6ebc9deaba1b1716ff4acbc3418f33496cd238421f6c015affd925ed8f61107a70ba373fe9cc5f89ea3c1b4050f44513b56d28eb11d
DIST pyglet-2.0.6.gh.tar.gz 6187140 BLAKE2B 25402453f0f8aaa8c300d0bad201ca92f220604b4b3420f27947cd157065ece157993eebfeb142981ad187b62120b6df791a95e362bedd5cf6208fba64ab4d57 SHA512 f6382362d2c314e4a388252f0674ed9a4a976eeb4ef767946c1570948be77cc53bb1ffd9b4e5550a3c235b0e56206fce94fed48da09c06cb1a3ebced92ecbb7d
+DIST pyglet-2.0.7.gh.tar.gz 6187601 BLAKE2B 00bebe51d6e4f2971aaaead69d483234528ed676b3a2b273fe6ee3c0b997d61490b9be3218c5caf092c83fdb58fb39051fde843845e63965e8e6c3510f873a90 SHA512 e51c63e12cfb450ef5b0ef8f113b50fd9a7ccd20f9afe61ef487c47a42248d674ca3bd300d3300bf3bfd5f45a9a029017a9fbf8dd7231f8b58c4b7354a4715cb
diff --git a/dev-python/pyglet/pyglet-2.0.7.ebuild b/dev-python/pyglet/pyglet-2.0.7.ebuild
new file mode 100644
index 000000000000..984c63405699
--- /dev/null
+++ b/dev-python/pyglet/pyglet-2.0.7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="Cross-platform windowing and multimedia library for Python"
+HOMEPAGE="
+ https://pyglet.org/
+ https://github.com/pyglet/pyglet/
+ https://pypi.org/project/pyglet/
+"
+SRC_URI="https://github.com/pyglet/pyglet/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples image +sound"
+
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/fontconfig
+ )
+"
+RDEPEND="
+ virtual/glu
+ virtual/opengl
+ image? ( || (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gtk+:2
+ ) )
+ sound? ( || (
+ media-libs/openal
+ media-sound/pulseaudio
+ ) )
+"
+# ffmpeg? ( media-libs/avbin-bin )
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ xdg_environment_reset
+
+ local EPYTEST_DESELECT=(
+ # lacking device/server permissions
+ tests/unit/media/test_listener.py::test_openal_listener
+ tests/unit/media/test_listener.py::test_pulse_listener
+ # fragile to system load
+ tests/unit/media/test_player.py::PlayerTestCase::test_pause_resume
+ tests/unit/test_clock_freq.py::test_elapsed_time_between_tick
+ )
+ if [[ ${EPYTHON} == python3.11 ]]; then
+ EPYTEST_DESELECT+=(
+ # broken test
+ # https://github.com/pyglet/pyglet/issues/606
+ tests/unit/test_events.py::test_push_handlers_instance
+ )
+ fi
+
+ # Specify path to avoid running interactive tests
+ # We could add in integration tests, but they're slow
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ nonfatal epytest tests/unit || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}