summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 06:50:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 06:50:21 +0200
commit4d759dbb05120ce49ab883cb16d920954ead7368 (patch)
treeb7b194b43175335c8b3ce978933e57375796a626 /dev-python
parentdev-python/cfn-lint: Bump to 0.87.5 (diff)
downloadgentoo-4d759dbb05120ce49ab883cb16d920954ead7368.tar.gz
gentoo-4d759dbb05120ce49ab883cb16d920954ead7368.tar.bz2
gentoo-4d759dbb05120ce49ab883cb16d920954ead7368.zip
dev-python/pytools: Bump to 2024.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytools/Manifest1
-rw-r--r--dev-python/pytools/pytools-2024.1.5.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytools/Manifest b/dev-python/pytools/Manifest
index 9653a72e755b..c8db3b052e08 100644
--- a/dev-python/pytools/Manifest
+++ b/dev-python/pytools/Manifest
@@ -1,3 +1,4 @@
DIST pytools-2024.1.2.tar.gz 77642 BLAKE2B b393149a81a708f3681b34e88e22113223f53f23e83c8f1848d4fd6ec456af7145fba8a98efd716d8be5b6184fc9973c05aa9c0814d48ee4925255b57f6119a5 SHA512 3252b3930934c43f840a77f41e0958fef6121db1d64efc5498defadf8e48fdbda89d1539b87b6367c8acf4ad7eaf7fdf364263340ffebd834861f0f21f1af4c7
DIST pytools-2024.1.3.tar.gz 79453 BLAKE2B 00d19b5e3918ae2e230db8778edcbaa8102436be1d82ee0a24f5f7504ef5f8ca5903c07386b5ebb1359138d4cb2f68840585b30e118f5dc1f3e2266230ec7d1d SHA512 89ee628af18ab68ebc1dab500a886cad243333a0ebf85128c1b06608b51638fc713e2d485b8d50bd3c70ab3143c46e789a49f7f7fc4fa8a14dd9644e7a822d72
DIST pytools-2024.1.4.tar.gz 79234 BLAKE2B e0cbca8c1b6556a6865d21c6b94591d19e50bdae3f8216bbfa55e965ccf236b8265fb25acaee8d939f7e187da8a39f618196e9b567b18700d92bc857de26952c SHA512 110a0672ba069a41dedc7e45dc407c5027e3c1384ab62706e04326e4b158b09a69822d51cadc6a164cdd20b361a7d82ad632ba072cfc0d6e7be449596d295374
+DIST pytools-2024.1.5.tar.gz 80774 BLAKE2B 37e9e14d5a62cdad34ddbfd0eabec747c392ba1506aacc76322f090699192369915882ba948fa07cd7a45369d3391343d9b2554def851e844976bc0442ddcfb6 SHA512 af7b79f1e26a43459765627ce6e6740953c38e05e26f3ec17360ccdf588ac320eabb5540fbbf9570cde324b8aae2412878316e9930e5195f467dbf5b74ca76b8
diff --git a/dev-python/pytools/pytools-2024.1.5.ebuild b/dev-python/pytools/pytools-2024.1.5.ebuild
new file mode 100644
index 000000000000..38860936dd01
--- /dev/null
+++ b/dev-python/pytools/pytools-2024.1.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of tools missing from the Python standard library"
+HOMEPAGE="
+ https://mathema.tician.de/software/pytools/
+ https://github.com/inducer/pytools/
+ https://pypi.org/project/pytools/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+
+# NB: numpy is now an "extra" (optional) dep -- we can remove it from
+# RDEPEND If revdeps don't need it
+RDEPEND="
+ >=dev-python/numpy-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/typing-extensions-4.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest