summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-09 03:34:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-09 03:34:21 +0200
commit5b96e9b94cca1ff0c05e2477c8f9b4155a2f44d7 (patch)
tree4c48d96ee565b030fdcb0643798e67e917d316af /dev-python
parentdev-python/botocore: Bump to 1.29.150 (diff)
downloadgentoo-5b96e9b94cca1ff0c05e2477c8f9b4155a2f44d7.tar.gz
gentoo-5b96e9b94cca1ff0c05e2477c8f9b4155a2f44d7.tar.bz2
gentoo-5b96e9b94cca1ff0c05e2477c8f9b4155a2f44d7.zip
dev-python/boto3: Bump to 1.26.150
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.150.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 5919e4d7cf17..c4b2d6b0c633 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,3 +4,4 @@ DIST boto3-1.26.146.gh.tar.gz 658035 BLAKE2B 29104a4ebd16ca8b2a0631bb747ed8b5af9
DIST boto3-1.26.147.gh.tar.gz 658916 BLAKE2B a612b3edd3f1ad232cf504f96750e759bed5e7abebae375bd4ac2918913c5863b5ef9bd6a2e534f7d08799c826c0fcf65cdbdb687960136f0d05192792cb6102 SHA512 6b845401d46e34602584da2fc10ea9c36fcb55beef2ba2c8ad724d030c54968e74690580080f2da218bc7d7886d7fb3d4b22abfbd90b5af5d6d86c9f6c45b52f
DIST boto3-1.26.148.gh.tar.gz 659957 BLAKE2B cac68eca82a00d596cf03d833394d7da0cdde0b2159a5fac1592faf7b5ea5ca9d41ee20ca10164ffdfb717193b4173fcf5e377d426edb672bf8510a0f4d1fa67 SHA512 8df8029ff11faa6d864920a5b5690f2b895ed500aa45970a7f4da5f33b52415cdfd6f582671b0e8f80205efd73a697e8a0c05e4335e2d921f9204b74df6de23d
DIST boto3-1.26.149.gh.tar.gz 660823 BLAKE2B 3334e6dcaf537af992f02dc1c94cd24d4279bf67923956137d02f9ea75a9a2853e281bb5f63e94336e56530737651b12652a00d2db15be5919be700528c0a047 SHA512 dbae0e07b01558248b6a4c4645b48c55fbe091f609710ee49c17b4e0725e034a4ad19c9a868ea7b7d20695d67a5ef7cca454018be2f5da6340b00a5f45d31618
+DIST boto3-1.26.150.gh.tar.gz 661462 BLAKE2B 26deb3f3614c33508c85ceb0e1b61ebb03166e02bb4aaaad8b9ae55eed48e91c503f2e00bf8b5b00ccfc118a85d00f9bec4e715d4f6e42a3c06a1dea027fc0b6 SHA512 013f203fc67cdd73546d653ae2a0837e10031b3e352fd11cc33fe4f361cff2f48eee928c9e0530788f6057192fa7a99a80c49b61d4ea2bd202081eb18383ba01
diff --git a/dev-python/boto3/boto3-1.26.150.ebuild b/dev-python/boto3/boto3-1.26.150.ebuild
new file mode 100644
index 000000000000..2a4a7643203e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.150.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}