summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-13 04:49:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-13 05:12:17 +0200
commit8b9391e8e6b30c7e8951a37a521ab30d9425e92f (patch)
treeb703caf41738fd0374598047878d28e46436db2d /dev-python
parentdev-python/pyzotero: Remove old (diff)
downloadgentoo-8b9391e8e6b30c7e8951a37a521ab30d9425e92f.tar.gz
gentoo-8b9391e8e6b30c7e8951a37a521ab30d9425e92f.tar.bz2
gentoo-8b9391e8e6b30c7e8951a37a521ab30d9425e92f.zip
dev-python/pyzotero: Bump to 1.5.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.25.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index 922aaca8d821..a37a0c82d6c5 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1 +1,2 @@
DIST pyzotero-1.5.20.tar.gz 526300 BLAKE2B 7f9110d70843563ce675c2efadc2e7f336671e4e6c9b70ead48dfec1680dd48ec3b4f6ea2898ed37e4548bca4cdeb68d4f50e68f617aefcb94002c9fe1881a40 SHA512 925b1c735c05a251d19de64565e83a91a88e6f21ac9ce0a14bb6fe4288337ff3564623589d1bf1b3c3794d25081e72aa21b9582716a2e4391f404107a9d5a62a
+DIST pyzotero-1.5.25.tar.gz 527019 BLAKE2B 4acc2dcfa581df45d7db44f15cf2200a456b170036baee8b506e49e5edf020bc9330caa072fa6cac439f0bca3b093401d57a8b157090ea366fcdd55575782ec7 SHA512 7a5e897d54a2b9a87155a0dc47aa4414a746184deae6931ee3d277c5913fe813c87bf2c658b2567cfe526aac98e0d9d8e964c4a9de507f5be4becda539aacecd
diff --git a/dev-python/pyzotero/pyzotero-1.5.25.ebuild b/dev-python/pyzotero/pyzotero-1.5.25.ebuild
new file mode 100644
index 000000000000..07c2b497906d
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.25.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+
+LICENSE="BlueOak-1.0.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.11[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ >=dev-python/trove-classifiers-2024.7.2[${PYTHON_USEDEP}]
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest