summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-10-13 14:03:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-10-13 14:24:14 +0200
commit9683847375cba7a0a9ef552dff7663398f07843b (patch)
tree006c98b3bdad76a547e4ffb90e5c4f99b5a6db19 /dev-python
parentdev-util/catkin: Remove old (diff)
downloadgentoo-9683847375cba7a0a9ef552dff7663398f07843b.tar.gz
gentoo-9683847375cba7a0a9ef552dff7663398f07843b.tar.bz2
gentoo-9683847375cba7a0a9ef552dff7663398f07843b.zip
dev-python/empy: bump to 3.3.4; add py39
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/empy/Manifest1
-rw-r--r--dev-python/empy/empy-3.3.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/empy/Manifest b/dev-python/empy/Manifest
index 916446ae3c5b..648458fd5618 100644
--- a/dev-python/empy/Manifest
+++ b/dev-python/empy/Manifest
@@ -1 +1,2 @@
DIST empy-3.3.3.tar.gz 138429 BLAKE2B ed2ea352161bcd141620253e059255c6d6437d72d8e72075e1abc01efc496715ff07eb1e9baef70a631e752761f828f2f4750087da154c0a6df1434e47a8f0b7 SHA512 74c091d6dac39ad9ddb6f46963066dab1f8846565f77b1b0ad4352eda3534d4312b0e95d3682387d75c2f5553d678c6d3112471eec032e2bdea0e891dd8217b1
+DIST empy-3.3.4.tar.gz 138495 BLAKE2B 0040b26966d3d6c7911cc7957159084ddb610085affaa5cf214121fdb292c43b071df8990749e02c0c3ef46cba131188e0907b8ab7c28a0834498b505bec0a2e SHA512 5de8de26484468d180a2575bfc8302cb3d32004ed4d70768310b7564a9ed1bb880b8c1d862f419588b2b5baa8c3da8bc707eac41f3921e6136cc5bc3f47f1a3d
diff --git a/dev-python/empy/empy-3.3.4.ebuild b/dev-python/empy/empy-3.3.4.ebuild
new file mode 100644
index 000000000000..fa463ba9b70d
--- /dev/null
+++ b/dev-python/empy/empy-3.3.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful and robust templating system for Python"
+HOMEPAGE="http://www.alcyone.com/software/empy/"
+SRC_URI="http://www.alcyone.com/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86"
+IUSE="doc"
+
+python_test() {
+ "${PYTHON}" em.py sample.em | diff sample.bench -
+ if [[ ${PIPESTATUS[0]} -ne 0 || ${PIPESTATUS[1]} -ne 0 ]]; then
+ die "Testing failed with ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ dodir /usr/share/doc/"${PF}"/examples
+ insinto /usr/share/doc/"${PF}"/examples
+ doins sample.em sample.bench
+ #3.3 has the html in this funny place. Fix in later version:
+ dohtml doc/home/max/projects/empy/doc/em/*
+ dohtml doc/home/max/projects/empy/doc/em.html
+ dohtml doc/index.html
+ fi
+}