summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 10:00:37 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 10:02:15 +0200
commitb4cc3f41ada8ef074f9ff0450eaa862f9f36dadf (patch)
tree7b7c9b4425c174b5abb105279898bde168c5b446 /dev-python
parentdev-python/wtforms: Enable py3.11 (diff)
downloadgentoo-b4cc3f41ada8ef074f9ff0450eaa862f9f36dadf.tar.gz
gentoo-b4cc3f41ada8ef074f9ff0450eaa862f9f36dadf.tar.bz2
gentoo-b4cc3f41ada8ef074f9ff0450eaa862f9f36dadf.zip
dev-python/svgwrite: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/svgwrite/svgwrite-1.4.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/svgwrite/svgwrite-1.4.1-r1.ebuild b/dev-python/svgwrite/svgwrite-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..2b05b0613034
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.4.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="
+ https://github.com/mozman/svgwrite/
+ https://pypi.org/project/svgwrite/
+"
+SRC_URI="
+ https://github.com/mozman/svgwrite/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # fetches from the Internet
+ sed -i -e 's:test_embed_google_web_font:_&:' \
+ tests/test_style.py || die
+ distutils-r1_src_prepare
+}