summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-07-26 23:15:46 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-02 21:14:42 +0300
commitbc6ccad3aa985c47a13cd975cc9db8746dc00848 (patch)
tree56cf30177335ed7f1c5ef84da30cfdc7df06aa6a /dev-python
parentdev-python/dissononce: New package (diff)
downloadgentoo-bc6ccad3aa985c47a13cd975cc9db8746dc00848.tar.gz
gentoo-bc6ccad3aa985c47a13cd975cc9db8746dc00848.tar.bz2
gentoo-bc6ccad3aa985c47a13cd975cc9db8746dc00848.zip
dev-python/transitions: New package
This is a new dependency for the >=net-im/yowsup-3 version bump. Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/transitions/Manifest1
-rw-r--r--dev-python/transitions/metadata.xml22
-rw-r--r--dev-python/transitions/transitions-0.6.9.ebuild46
3 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/transitions/Manifest b/dev-python/transitions/Manifest
new file mode 100644
index 000000000000..8d1cbfa876df
--- /dev/null
+++ b/dev-python/transitions/Manifest
@@ -0,0 +1 @@
+DIST transitions-0.6.9.tar.gz 1354465 BLAKE2B bb536c1209c08717b29d5d60e4b31253b1f5bc759b7693a3ef82d4894cd55bc8a2dd3417e03ba5232d35de060c73cef664994c44c8f14be9ed0743170e7c1c09 SHA512 8104d98795c4212e40ba8274332e2e87336421e61a4398c58907a675708cddc7d3b77bbcada1e2cc16fd9dd518c94f07c2079cf0507b8647a435435151f5eb51
diff --git a/dev-python/transitions/metadata.xml b/dev-python/transitions/metadata.xml
new file mode 100644
index 000000000000..a48ef5d38ade
--- /dev/null
+++ b/dev-python/transitions/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ A lightweight, object-oriented state machine implementation in Python.
+ A state machine is a mathematical model of computation.
+ It is an abstract machine that can be in exactly one of a
+ finite number of states at any given time.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/pytransitions/transitions/issues</bugs-to>
+ <remote-id type="github">pytransitions/transitions</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/transitions/transitions-0.6.9.ebuild b/dev-python/transitions/transitions-0.6.9.ebuild
new file mode 100644
index 000000000000..65a89daacacf
--- /dev/null
+++ b/dev-python/transitions/transitions-0.6.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight, object-oriented state machine implementation in Python"
+HOMEPAGE="https://github.com/pytransitions/transitions"
+SRC_URI="https://github.com/pytransitions/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/dill[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ use examples && dodoc examples/*.ipynb
+}