summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-25 07:40:48 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-25 08:06:19 +0100
commitcc8fb5c1da51a123f6973486dd5b9893b8c24f66 (patch)
treed0b8f74767bb0dcc79a4524df9722aada9c96c84 /dev-python
parentprofiles/base: extend gcc rust mask (diff)
downloadgentoo-cc8fb5c1da51a123f6973486dd5b9893b8c24f66.tar.gz
gentoo-cc8fb5c1da51a123f6973486dd5b9893b8c24f66.tar.bz2
gentoo-cc8fb5c1da51a123f6973486dd5b9893b8c24f66.zip
dev-python/patsy: Bump to 0.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/patsy/Manifest1
-rw-r--r--dev-python/patsy/patsy-0.5.5.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/patsy/Manifest b/dev-python/patsy/Manifest
index c36a3d727277..6df5ec871904 100644
--- a/dev-python/patsy/Manifest
+++ b/dev-python/patsy/Manifest
@@ -1 +1,2 @@
DIST patsy-0.5.4.tar.gz 397809 BLAKE2B d10a4a155d3346b7a5968af914e68f1c2508208eda5658091b40c4df421c6b5566278bfe7db856793a477cb9c78ed7bc8aae4209dde7b476d0d8a19164602797 SHA512 4fa6b099a12464b1ad1685e0d9ca0e9640c059d5021631e6c52f4025ff100899824e722d9b12107c49dc987e8f3e377aeeb007889d8b35b3f1e4cdf5ca491d2f
+DIST patsy-0.5.5.tar.gz 398073 BLAKE2B 39f2f0d7d855fc3a4ae4a8930847c859aeacd74232fbc46c5455d10fe9cf0940ce5dea5322927df7b6aed61799e9ecbb6156cd2d142e0e965dc3b208896b1f7d SHA512 9df823094223e4929ece2d35696288cfb1ce0395cc3a322b88b582439dbe85ae69d81c876deef2cedebcd4763a57cc7289bdc74f77cb6a514d1f2c3a9332a7f4
diff --git a/dev-python/patsy/patsy-0.5.5.ebuild b/dev-python/patsy/patsy-0.5.5.ebuild
new file mode 100644
index 000000000000..d2134e279146
--- /dev/null
+++ b/dev-python/patsy/patsy-0.5.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module to describe statistical models and design matrices"
+HOMEPAGE="
+ https://patsy.readthedocs.io/en/latest/index.html
+ https://github.com/pydata/patsy/
+ https://pypi.org/project/patsy/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/scipy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest