summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-07 06:03:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-07 06:03:22 +0200
commitecbab633dff3db492e5020f3b17faae8c12d18ee (patch)
tree19681ce9cecffd271b7e60518fd203b1c5ad30b6 /dev-python
parentsys-libs/glibc: switch to external locale-gen (diff)
downloadgentoo-ecbab633dff3db492e5020f3b17faae8c12d18ee.tar.gz
gentoo-ecbab633dff3db492e5020f3b17faae8c12d18ee.tar.bz2
gentoo-ecbab633dff3db492e5020f3b17faae8c12d18ee.zip
dev-python/logical-unification: Bump to 0.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/logical-unification/Manifest1
-rw-r--r--dev-python/logical-unification/logical-unification-0.4.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/logical-unification/Manifest b/dev-python/logical-unification/Manifest
index f4d929eeae85..e3ab54e77a40 100644
--- a/dev-python/logical-unification/Manifest
+++ b/dev-python/logical-unification/Manifest
@@ -1 +1,2 @@
DIST logical-unification-0.4.5.gh.tar.gz 47003 BLAKE2B 9f7e119a69b15b460ce66af137a3f0c3dd3da154173ac196a94d4894aafc67eeaa31d69c5ca8bdd6e264a3f7599f9e301dad103510c77e60ff14cc8af1c86ce8 SHA512 42af33ac7da6013d48d26ab49b84b40146f494963f1eee06256a219e8d0517b04cc3fe86f51cf19729fc64ad765e75a4890b278c2dbbf34eb7e1ef65f3014784
+DIST logical-unification-0.4.6.gh.tar.gz 47171 BLAKE2B 894db9bfc94b1b4ed496376bb45dd6f71db89f57ff73ab4bfacd12e991817751c4213b36d6e19d34b239e1335dcbe7b71ab283d419bab92554dacc539355ae7e SHA512 6caf91823acbaf0341d7d515610bbe351882f1b6fdff064fc900adb56387c6023a49743b0ad5f6f1c6af42e79b53ac1d1540a4ce3c42dca5fd79f0abec9f653c
diff --git a/dev-python/logical-unification/logical-unification-0.4.6.ebuild b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
new file mode 100644
index 000000000000..a4d2f2079412
--- /dev/null
+++ b/dev-python/logical-unification/logical-unification-0.4.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Logical unification in Python"
+HOMEPAGE="
+ https://pypi.org/project/logical-unification/
+ https://github.com/pythological/unification/
+"
+# No tests in sdist, as of 0.4.6
+SRC_URI="
+ https://github.com/pythological/unification/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/unification-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ dev-python/multipledispatch[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ tests/test_benchmarks.py
+)