summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-03 12:41:05 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-04 00:36:57 +1100
commit30bf416f5c909f3bc8d09ca5761529e97f441d2a (patch)
treeffad87efb451c904c3c3aad4c1dbcc8a19f5cb5e /dev-qt/qtwayland
parentqt5-build.eclass: introduce QT5_GENTOO_PRIVATE_CONFIG (diff)
downloadgentoo-30bf416f5c909f3bc8d09ca5761529e97f441d2a.tar.gz
gentoo-30bf416f5c909f3bc8d09ca5761529e97f441d2a.tar.bz2
gentoo-30bf416f5c909f3bc8d09ca5761529e97f441d2a.zip
dev-qt: version bump 5.9.4
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.9.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 29f1f66c00f8..67b1c7124589 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-opensource-src-5.7.1.tar.xz 291776 BLAKE2B 06aba415e33ed971ef4de975e8677a52c4fcc81922f978cc1bde7e9a7ebdea32cd1c7dca59b67493bc96edfd997027f630c05c93ce31ae4ba87a55580495997a SHA512 41a6699b9048a859bb0cb1e37cd0a3977f52a5a223d4f6a4ce5e1402c5b829cc907593ce2b70f4ec24dfad147251bb2f20e889eae26072cf53e774b4585f2921
DIST qtwayland-opensource-src-5.9.3.tar.xz 314652 BLAKE2B 56dbb8baa3642144d7021ca4361f4a574efe520f759dcc09867e4f114fc449ebd011099fb852c758c524e79539d5e6365cd3863921dc42339ba9c770586d21d7 SHA512 1deb41d3a2e081fa434167211b975019840c56cbf04c8fc18325d405818c2ecee6d65c9376f498ddacc1587455d310b815d56124d6a7734b2857399abfb3b659
+DIST qtwayland-opensource-src-5.9.4.tar.xz 314932 BLAKE2B de90fb47af0d07e0b6476b84de2f51900e4e09ecd57aee800534998d3a2e733501da877f912c4b0ce671d417f543eb44bc1607225af0a134ba5702d17efae431 SHA512 93d43bdcc39fd471cdd335c0699c5e5dd77cd0bc2d15f2a1170d8ccd103d84e2c7e657575a370ac6c678b52c2b617fb2c80ce4d226264cb6c857064452f7dc10
diff --git a/dev-qt/qtwayland/qtwayland-5.9.4.ebuild b/dev-qt/qtwayland/qtwayland-5.9.4.ebuild
new file mode 100644
index 000000000000..4c3553046dbc
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.9.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput?]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}