summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-08-04 13:17:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-08-05 13:31:47 +0200
commit93b7703d16433d6e05757da9cfaec5e70405e789 (patch)
tree70915733b0169dae9cc4a94adfe999d2f75c80c8 /dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
parentdev-ros/ament_copyright: bump to 0.11.2 (diff)
downloadgentoo-93b7703d16433d6e05757da9cfaec5e70405e789.tar.gz
gentoo-93b7703d16433d6e05757da9cfaec5e70405e789.tar.bz2
gentoo-93b7703d16433d6e05757da9cfaec5e70405e789.zip
dev-ros/ament_pep257: bump to 0.11.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild')
-rw-r--r--dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild b/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
new file mode 100644
index 000000000000..d68cc9cf4ecc
--- /dev/null
+++ b/dev-ros/ament_pep257/ament_pep257-0.11.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Checks code against style conventions in PEP 8 and generate test result files"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ PROPERTIES="live"
+else
+ KEYWORDS="~amd64"
+fi
+IUSE="test"
+
+RDEPEND="
+ dev-ros/ament_lint[${PYTHON_USEDEP}]
+ dev-python/pydocstyle[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/ament_flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND=""
+
+distutils_enable_tests pytest