summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2019-12-11 15:36:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2019-12-11 16:26:25 +0100
commit5855c2107f1eb92b0ea9e6ceada4efeb51ffd98f (patch)
tree4a29291cb2e1bcb31c1b9982b46606a668a1a7b7 /dev-ros/rosbash
parentros-meta/ros: Bump to 1.14.7. (diff)
downloadgentoo-5855c2107f1eb92b0ea9e6ceada4efeb51ffd98f.tar.gz
gentoo-5855c2107f1eb92b0ea9e6ceada4efeb51ffd98f.tar.bz2
gentoo-5855c2107f1eb92b0ea9e6ceada4efeb51ffd98f.zip
dev-ros/rosbash: fix patch
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbash')
-rw-r--r--dev-ros/rosbash/files/catkin_prefix.patch13
-rw-r--r--dev-ros/rosbash/rosbash-1.14.7.ebuild2
-rw-r--r--dev-ros/rosbash/rosbash-9999.ebuild4
3 files changed, 16 insertions, 3 deletions
diff --git a/dev-ros/rosbash/files/catkin_prefix.patch b/dev-ros/rosbash/files/catkin_prefix.patch
new file mode 100644
index 000000000000..89877b005f9d
--- /dev/null
+++ b/dev-ros/rosbash/files/catkin_prefix.patch
@@ -0,0 +1,13 @@
+Index: rosbash/scripts/rosrun
+===================================================================
+--- rosbash.orig/scripts/rosrun
++++ rosbash/scripts/rosrun
+@@ -47,7 +47,7 @@ case $2 in
+ ;;
+ esac
+
+-if [[ -n $CMAKE_PREFIX_PATH ]]; then
++if [[ -n $CMAKE_PREFIX_PATH || -n $CATKIN_PREFIX_PATH ]]; then
+ _rosrun_IFS="$IFS"
+ IFS=$'\n'
+ catkin_package_libexec_dirs=($(catkin_find --without-underlays --libexec --share "$1" 2> /dev/null))
diff --git a/dev-ros/rosbash/rosbash-1.14.7.ebuild b/dev-ros/rosbash/rosbash-1.14.7.ebuild
index 1b7d1d2120d9..3a58dab5f491 100644
--- a/dev-ros/rosbash/rosbash-1.14.7.ebuild
+++ b/dev-ros/rosbash/rosbash-1.14.7.ebuild
@@ -16,4 +16,4 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/catkin_prefix2.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )
diff --git a/dev-ros/rosbash/rosbash-9999.ebuild b/dev-ros/rosbash/rosbash-9999.ebuild
index f77828f9bf96..3a58dab5f491 100644
--- a/dev-ros/rosbash/rosbash-9999.ebuild
+++ b/dev-ros/rosbash/rosbash-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -16,4 +16,4 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/catkin_prefix2.patch" )
+PATCHES=( "${FILESDIR}/catkin_prefix.patch" )