summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 14:48:54 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:21 +0200
commit818593da6bae4279100f4a6624f274d44eb9ba21 (patch)
tree17570b228d91a3b4b383ce67244c6de9c307db8f /dev-ros/rosconsole/rosconsole-9999.ebuild
parentdev-ros/xmlrpcpp: Initial import. Ebuild by me. (diff)
downloadgentoo-818593da6bae4279100f4a6624f274d44eb9ba21.tar.gz
gentoo-818593da6bae4279100f4a6624f274d44eb9ba21.tar.bz2
gentoo-818593da6bae4279100f4a6624f274d44eb9ba21.zip
dev-ros/rosconsole: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rosconsole/rosconsole-9999.ebuild')
-rw-r--r--dev-ros/rosconsole/rosconsole-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ros/rosconsole/rosconsole-9999.ebuild b/dev-ros/rosconsole/rosconsole-9999.ebuild
new file mode 100644
index 000000000000..7d1cc2938086
--- /dev/null
+++ b/dev-ros/rosconsole/rosconsole-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS console output library"
+LICENSE="BSD"
+SLOT="0"
+IUSE="+log4cxx glog"
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rostime
+ dev-ros/rosunit
+ dev-libs/boost:=[threads]
+ log4cxx? ( dev-libs/log4cxx )
+ !log4cxx? ( glog? ( dev-cpp/glog ) )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local ROSCONSOLE_BACKEND=""
+ if use log4cxx; then
+ ROSCONSOLE_BACKEND="log4cxx"
+ elif use glog; then
+ ROSCONSOLE_BACKEND="glog"
+ else
+ ROSCONSOLE_BACKEND="print"
+ fi
+ local mycatkincmakeargs=( "-DROSCONSOLE_BACKEND=${ROSCONSOLE_BACKEND}" )
+ ros-catkin_src_configure
+}