summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 10:00:00 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:52 +0100
commit9101935e4d98324bf9370c635856a7399f964f60 (patch)
tree39285324d67a0a0ba0086f8376b7d833231bb119 /dev-ros/topic_tools/topic_tools-1.13.0.ebuild
parentdev-ros/rostopic: Bump to 1.13.0. (diff)
downloadgentoo-9101935e4d98324bf9370c635856a7399f964f60.tar.gz
gentoo-9101935e4d98324bf9370c635856a7399f964f60.tar.bz2
gentoo-9101935e4d98324bf9370c635856a7399f964f60.zip
dev-ros/topic_tools: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/topic_tools/topic_tools-1.13.0.ebuild')
-rw-r--r--dev-ros/topic_tools/topic_tools-1.13.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ros/topic_tools/topic_tools-1.13.0.ebuild b/dev-ros/topic_tools/topic_tools-1.13.0.ebuild
new file mode 100644
index 000000000000..232d4bad6d9f
--- /dev/null
+++ b/dev-ros/topic_tools/topic_tools-1.13.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for directing, throttling and selecting ROS topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cpp_common
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostime
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"